System not freeing up memory/Programs continually using up more and more memory

fstab.pdf (12.8 KB)

Please do not post .pdf output. Please post the contents of terminal output.

$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# file system>             mount point>  type>  options>  dump>  pass>
UUID=6193-8309                            /boot/efi      vfat    umask=0077 0 2
UUID=d59f7485-ddc8-488f-a542-fbb4bb85e077 /              ext4    defaults,noatime 0 1
UUID=ceed562c-6375-46ae-abb0-cc235785fc4b swap           swap    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
1 Like

Please format the output correctly. I will edit your post as an example.

I didn’t see anything out of the ordinary here?

I had to reboot my PC using the power button for the third time today. I saw a message in the exit terminal or whatever it’s called about orphaned inodes. At this point, I don’t think there’s much you guys can do. I’ll try some things, and keep you updated. Thank you so much for your support, though :smile:


This is not solving your problem, but I would suggest not rebooting your PC using the power button as that can create additional problems. You should enable the Magic SysRq key so you can safely reboot at any time, no matter what the state of your computer is. The orphaned inodes might just be a consequence of you powering off your PC like that.

1 Like

I don’t quite understand this statement. I know you posted it 2 days ago, but your log shows that you had reinstalled on 9/4 - which is much more than just a couple of days ago. Was this a complete install, or did you do something interesting in the install process? Like, was this a complete fresh EnOS install or did you keep something from your prior Arch install?

I just wanted to make sure it’s not some gremlin from a prior installation. Especially since it sounds like it may not be just EnOS specific.

My bad. I had Arch installed for a month before I completely wiped and reformatted the SSD it was on several days ago. So it was a complete fresh install of Arch, I just kept a list of programs I redownloaded from the AUR.

A fresh install of Arch? Or an install using EndeavourOS?

Fresh install using EndevOS. My bad, again.

1 Like

Well all these issues don’t make any sense to me if all this is true. Linux just doesn’t work like this. So you are going to have to check all your hardware and see if anything is faulty. I don’t know what else to tell you.


How did you wipe and format. i would remove other drives before doing any thing, do a stress test on it and your ram.
then do as it says here

Trim an entire device

If you want to trim your entire SSD at once, e.g. for a new install, or you want to sell your SSD, you can use the blkdiscard command, which will instantly discard all blocks on a device.

Warning: all data on the device will be lost!

blkdiscard /dev/sd X change the x to your drive letter /dev/sda for example

And hardware? Kernel info? Please post output of inxi -Fxxxza --no-host

I must say, that is a very interesting issue, especially since it crosses distro lines… . so you would think it would be a Plasma issue, . .

Just out of curiosity, have you tried Fedora or MX? Something not Arch based with the same results? Or XFCE? Are your sure it’s a Plasma issue?

You’ve got a relatively new install, I’d distro hop at least a couple more times personally if you weren’t having the issue prior to your Arch install. What were you running before that? Just Windows?

Does the problem also occur while you’re using Windows?

What’s wrong with this? What and how many programs is “some” programs? What happens when you close them? Linux fundamentally used RAM differently than Windows, so it may not go down just because you close everything. The Linux ate my RAM website is helpful.

How did you setup swap? It looks like you have 16GB RAM and 9 GB swap? Why the breakdown and was this a swap partition or file? I don’t think EnOS automatic partitioning would do that, so during install what was the reasoning for such allocation?

I’m just trying to find what you’re doing differently than us. Something doesn’t make sense in your install, or you have some faulty piece of hardware. I’m currently on 6.5 days of uptime on this machine. It’s also running Plasma, and I’m still only using 2.5GB of RAM as I open and close things.

[derek@archlinuxkde ~]$ uptime
 01:57:21 up 6 days,  9:35,  3 users,  load average: 0.69, 0.66, 0.47
[derek@archlinuxkde ~]$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15893        1699       11750         626        2443       13259
Swap:         16383           0       16383
[derek@archlinuxkde ~]$ 

1 Like
System:    Kernel: 5.8.8-arch1-1 x86_64 bits: 64 compiler: N/A 
     parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=d59f7485-ddc8-488f-a542-fbb4bb85e077 rw quiet 
     resume=UUID=ceed562c-6375-46ae-abb0-cc235785fc4b loglevel=3 nowatchdog 
     Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: EndeavourOS 
     Machine:   Type: Desktop Mobo: MSI model: X370 GAMING PLUS (MS-7A33) v: 3.0 serial: <filter> UEFI: American Megatrends v: 5.H0 
     date: 01/22/2019 
CPU: Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 
     microcode: 800820D L2 cache: 4096 KiB 
     flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118419 
     Speed: 2405 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 2423 2: 2425 3: 1891 4: 1893 5: 2180 
     6: 2188 7: 2275 8: 2957 9: 1716 10: 1719 11: 1715 12: 1718 13: 1714 14: 1723 15: 2182 16: 2187 
     Vulnerabilities: Type: itlb_multihit status: Not affected 
     Type: l1tf status: Not affected 
     Type: mds status: Not affected 
     Type: meltdown status: Not affected 
     Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
     Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
     Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
     Type: srbds status: Not affected 
     Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] vendor: ASRock 
    driver: amdgpu v: kernel bus ID: 2b:00.0 chip ID: 1002:731f 
    Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu FAILED: ati 
    unloaded: fbdev,modesetting,radeon,vesa display ID: :0 screens: 1 
    Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
    Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8") 
    Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 2b:00.1 
    chip ID: 1002:ab38 
    Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
 bus ID: 2d:00.3 chip ID: 1022:1457 
       Device-3: C-Media USB Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3:2 
       chip ID: 0d8c:0012 
       Sound Server: ALSA v: k5.8.8-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
       v: 8.048.03-NAPI modules: r8169 port: f000 bus ID: 21:00.0 chip ID: 10ec:8168 
       IF: enp33s0 state: down mac: <filter> 
       Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 bus ID: 25:00.0 chip ID: 8086:2723 
       IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 3.64 TiB used: 208.01 GiB (5.6%) 
       SMART Message: Unable to run smartctl. Root privileges required. 
       ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS200T3X0C-00SJG0 size: 1.82 TiB block size: physical: 512 B 
       logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 102430WD scheme: GPT 
       ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB block size: physical: 512 B logical: 512 B 
       speed: 6.0 Gb/s serial: <filter> rev: 4B6Q scheme: GPT 
       ID-3: /dev/sdb vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB block size: physical: 512 B logical: 512 B 
       speed: 6.0 Gb/s serial: <filter> rev: 4B6Q scheme: GPT 
Partition: ID-1: / raw size: 922.42 GiB size: 906.94 GiB (98.32%) used: 208.01 GiB (22.9%) fs: ext4 dev: /dev/sda2 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
       ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 38.9 C mobo: N/A gpu: amdgpu temp: 40.0 C mem: 40.0 C 
       Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 383 Uptime: 1m Memory: 15.64 GiB used: 1.52 GiB (9.7%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
       clang: 10.0.1 Packages: 1079 pacman: 1065 lib: 262 flatpak: 14 Shell: Bash v: 5.0.18 running in: konsole 
       inxi: 3.1.06 

For question 1 and 2, I did use Kubuntu several months ago, but it broke on me one day, so I resumed using Windows for a while.

Does the problem also occur while you’re using Windows?

Not as far as I can tell. I was just asking that question since I heard from some people that Windows can mess up Linux installations, and was wondering if that was the issue :slight_smile:

What’s wrong with this? What and how many programs is “some” programs? What happens when you close them? Linux fundamentally used RAM differently than Windows, so it may not go down just because you close everything. The Linux ate my RAM website is helpful.

It uses a ton of memory application wise. To reiterate, programs in my linux install will continually use more and more memory, and will never decrease in usage. When I used my PC for 3 days without rebooting it, it was using 5.5 GiB of memory, excluding disk cache. Besides, I don’t think it’s normal for Plasma Shell or Discord to use so much memory. It’s annoying for me, since I frequently play games and use Virtual Machines on my PC.

How did you setup swap? It looks like you have 16GB RAM and 9 GB swap? Why the breakdown and was this a swap partition or file? I don’t think EnOS automatic partitioning would do that, so during install what was the reasoning for such allocation?

This is a swap partition. My intent was to have a 8GB swap partition but I must have messed up somewhere.

What other kernels have you tried? A LOT of problems are due to the Kernel. Please give the linux-lts kernel a go at the very least. Unless you have some hardware that is say, less than 6 months old, lots of people benefit from the LTS kernel. You may be in that category since you said that you said it’s MSI gaming computer.

And my question I asked is why is that a problem? You’ve made it clear you think it’s a problem, but what makes you positive that it is the issue? At 3 days and 5.5GB of memory consumption isn’t necessarily a bad thing at all. Upon turning my computer on I baseline at like 500mb of RAM, and after opening a bunch of stuff and then closing all of it, I will probably never drop below 2GB of “usage” again.

You have 16GB of RAM, 5.5GB is not a problem. Did you check out yet? The first line explains:

What’s going on?

Linux is borrowing unused memory for disk caching. This makes it looks like you are low on memory, but you are not! Everything is fine!

Don’t think. . . Or it’s not normal? Prior to your Arch install a couple months ago, what distro(s) were you using? What kind of memory usage were you seeing there? Or is this just in comparison to Windows?

Does this happen when you’re not using a VM? VM’s, especially if you’re using them for gaming, can be extremely resource heavy. And depending on how you setup your VM system with RAM allocation, that could without question be what is causing freezes. I’m not very good with VM’s so I’ll let someone else chime on that, but whatever you allocate to a VM I believe is resources your computer flat out cannot use. So, if you need 8GB for a VM, you don’t have 16GB anymore, you have 8, and your swap should be bigger to help with that. Especially if you wanted hibernate to work, which it won’t unless swap is at least equal to RAM. Most of the guys who use VM’s are over 16GB of RAM these days.

With that you’ve exhausted my knowledge of what I am able to help you with. If I were me, my first go would be to switch and use the linux-lts kernel. And if that doesn’t work, I would do another complete reinstall, and use the automatic paritioning this time. Just let it do it’s thing. Unless you know what you’re tweaking, you may be doing more harm than good. Also I noticed that for fan speeds it says N/A. . . if you’re overheating, you could be throttling and feeling like it’s frozen as well.

If anyone else has ideas, please feel free. I’m not really sure what else to suggest at this point.

With the hardware you are running you should not be having the issues you are having. Although I have a somewhat newer setup yours is no slouch. My plasma set up is very fast & responsive and uses no swap and very little ram. Windows installed on another drive shouldn’t have anything to do with it unless you have some unorthodox setup I’m not aware of .

I replaced my motherboard and RAM, and wiped my EndevOS again, and then reinstalled it. Even on a fresh install, it still has the same issues. I think my computer just might be allergic to Linux at this point. Thank you all for trying to help.

1 Like

It’s not. And I’m sure with more questions we can figure it out. I’m very sure it has something to do with your VMs and not understanding Linux RAM usage. But I would be very frustrated after all of that, especially replacing pieces and still not fixing anything. I’m sorry to hear that.

But alas, Linux isn’t for everyone/everything. Good luck wherever it takes you from here!