System not booting

Did -syu updates and had to reboot, after that I got stuck with this message. Have no idea what could it be so have no more information to give.
16691442792115713055930316041110

Thanks in advance

How long did you wait for the boot-process to finish? It may look like that (your picture) on any boot of Arch Linux / EndeavourOS.

Yeah that’s the problem there is no error messages or something but it’s been like this for 15 mins at least

Did the update finish successfully? No error messages?

You could try chrooting into your system using your live usb and run the the updates again.

Then you’d have to boot from a Live-USB, and arch-chroot into the installed system on /dev/sdb2.

From there, you should post here the output of lsblk -f and that of inxi -Fzgxa and wrap the pasted content from your terminal in code-tags in your post-editor on this forum for enabling friends here to help you out.

The “recovering journal” means something was not normal in previous shutdown.
Did you happen to shutdown/reboot too early?

1 Like

Yeah all updates finished, and after that I used system normally for an hour and then rebooted with sudo reboot now.

1 Like

So here is the result of lsblk -f

[root@EndeavourOS /]# lsblk -f
NAME   FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
loop0                                         
sda                                           
├─sda1                                        
├─sda2                                        
├─sda3                                        
├─sda4                                        
└─sda5                                        
sdb                                           
├─sdb1                          298.8M     0% /boot/efi
└─sdb2                          390.6G     9% /
sdc                                           
├─sdc1                                        
└─sdc2                                        
sr0                                           
sr1   

and and for “inxi -Fzgxa” was
Error 22: Unsupported option: -gxa Check -h for correct parameters.
So here is “inixi -F”

[root@EndeavourOS /]# inxi -F
12System:
  12Kernel 5.18.16-arch1-1 12arch x86_64 12bits 64 12Console N/A 12Distro EndeavourOS
12Machine:
  12Type Laptop 12System Acer 12product TMP455-M 12v V2.10 12serial <filter>
  12Mobo Acer 12model BA51_HW 12v V2.10 12serial <filter> 12UEFI Insyde 12v 2.10 12date 04/18/2014
12Battery:
  12ID-1 BAT1 12charge 30.7 Wh (100.0%) 12condition 30.7/37.0 Wh (82.9%)
12CPU:
  12Info dual core 12model Intel Core i5-4200U 12bits 64 12type MT MCP 12cache 12L2 512 KiB
  12Speed (MHz) 12avg 2254 12min/max 800/2600 12cores 121 2131 122 2295 123 2295 124 2295
12Graphics:
  12Device-1 Intel Haswell-ULT Integrated Graphics 12driver i915 12v kernel
  12Device-2 Sunplus Innovation HD WebCam 12type USB 12driver uvcvideo
  12Display 12server X.org 12v 1.21.1.4 12driver 12gpu i915 12note X driver n/a 12resolution 121 2560x1440
    122 1920x1080
  12API OpenGL 12Message GL data unavailable for root.
12Audio:
  12Device-1 Intel Haswell-ULT HD Audio 12driver snd_hda_intel
  12Device-2 Intel 8 Series HD Audio 12driver snd_hda_intel
  12Sound API ALSA 12v k5.18.16-arch1-1 12running yes
  12Sound Server-1 PipeWire 12v 0.3.60 12running yes
12Network:
  12Device-1 Broadcom NetXtreme BCM57786 Gigabit Ethernet PCIe 12driver tg3
  12IF enp1s0f0 12state down 12mac <filter>
  12Device-2 Qualcomm Atheros AR9462 Wireless Network Adapter 12driver ath9k
  12IF wlan0 12state up 12mac <filter>
12Bluetooth:
  12Device-1 Foxconn / Hon Hai 12type USB 12driver btusb
  12Report bt-adapter 12ID hci0 12state up 12address N/A
12Drives:
  12Local Storage 12total 732.36 GiB 12used 42.52 GiB (5.8%)
  12ID-1 /dev/sda 12vendor Samsung 12model MZ7LN256HCHP-00000 12size 238.47 GiB
  12ID-2 /dev/sdb 12type USB 12model Ext Hard Disk 12size 465.07 GiB
  12ID-3 /dev/sdc 12type USB 12vendor Kingston 12model DataTraveler 2.0 12size 28.82 GiB
12Partition:
  12ID-1 / 12size 456.4 GiB 12used 42.52 GiB (9.3%) 12fs ext4 12dev /dev/sdb2
  12ID-2 /boot/efi 12size 299.4 MiB 12used 600 KiB (0.2%) 12fs vfat 12dev /dev/sdb1
12Swap:
  12Alert No swap data was found.
12Sensors:
  12System Temperatures 12cpu 40.0 C 12mobo N/A
  12Fan Speeds (RPM) N/A
12Info:
  12Processes 200 12Uptime 20m 12Memory 9.6 GiB 12used 1.95 GiB (20.3%) 12Client Unknown Client: systemd
  12inxi 3.3.23

Sorry for my blurp on inxi!

It should really have been inxi -F like you provided.

1 Like

What happens if you update your installed system in the (Live-USB booted) arch-chroot environment with yay?

Updated everything normally and I tried to boot again and same.
Could it be something with my new monitor, like hardware related even though I tried without monitor and still no changes…
I’m really sorry for boring you and thanks for trying to help me

Try this from the live session (no need to chroot):

sudo fsck -y /dev/sdb2

When it is done, reboot.

You could also do this via Gparted. Launch it from the application menu, right click on the system partition and choose: Check and apply in the tool bar.

1 Like

Try booting the fallback image (at Grub menu) and/or alternative kernels, if you have.

Sadly didn’t help

1 Like

Is there at least any way to save all my data or something? I’ll probably do a fresh install or try another DE.

There are many ways, for example terminal commands or file manager.
It is a good idea to copy your data to an external driver, like USB stick or external SSD drive.

If you cannot boot normally to your system, you can use the USB installer stick for booting.

Nice terminal commands for copying data are e.g. cp or rsync.
Use terminal commands

man cp
man rsync
man ls      # use 'ls -la' to see your files

to get more information about them.

With file manager you can drag and drop your personal files from the hard drive to the external drive.
Note that if you want to copy the “hidden” files (e.g. ~/.bashrc) too, then you may need to make the file manager to show them.

2 Likes