System no longer boot after update

After last update my system will not boot anymore. It goes as far as cleaning system and hangs there. I got it into the ttly mode and tried to start the desktop but xorg reported error of missing files. I can reinstall Endeavours but I need to either to be able to dump all my data off the hard drive or fix the booting problem. My version of Endeavor is three years old so it most likely needs to be upgraded. Any help would be greatly appreciated. I did try a live session but it will not allow me to access the main drive, only the secondary one.

Perhaps you could try arch-chroot-ing into your system from a Live usb and see if there might be something to be done to rescue the system.

Things to try in chroot could be to run the update again, to rebuild the initramfs, to reinstall the bootloader and regenerate the grub.cfg. However these two last steps might not be needed since you seem to get passed Grub.

In the live session, before you mount your system partitions for chrooting, you could launch Gparted and run a check on the filesystems.

If you can access the TTY, then you should be able to copy all your files to a another (backup) drive.

Yes but how to copy the file from TTY? I searched the internet for how but could find the answer. I tried mounting the drives from TTY and could but could not mount them with the command for the fstab. Came up with an error saying that the fstab file did not exist. How ever if I can make a data dumb to a usb drive I would be really happy. I just wished I would of done a backup prior to doing this last update.

Well I gave it a collage try, manage to mount all the drives. However was not able to make them accessible. So I have just reinstalled Endeavours on my desktop. Luckily I didn’t loose much, mostly some new programs that I had written. Anyways thank to the help. Just wish when the do the updates that they do it right.

TTY (and a terminal) is a very capable way to run system commands.
For the record, mounting on the command line can be done with the mount command. See help with command

man mount

If there are permission problems, you can use command


to change file and folder permissions. See the manual page:

man chmod

And to see the disks and partitions in your system for the mount operation, you can use e.g. command

lsblk -fm


man lsblk

for more info.

Of course, some commands need elevated privileges. That can be achieved by adding word


in front of a command, e.g.

sudo mount "your-parameters-here"

Are you using nvidia drivers? I’m unsure if it is related but I have a similar problem with the latest updates breaking my boot: System does not boot after update (nvidia?) - Stuck at Network Manager Script Dispatcher Service

If it isn’t I can give a tip to install timeshift (with timeshift-autosnap hook) for the future to create snapshots. It saved my boot by allowing me to revert to before I did the update

Thanks manuel for that info. I will use it in the future if it every happens again. My system is back up and running again, with little lost stuff. Mainly some programs I wrote.

Would you mind sharing how you rescued your system for future reference for other users having similar issue?

Pebcak I didn’t, I ended up installing the latest version of Endeavour. Luckly I did have my important stuff backed up, so I didn’t loose much.

1 Like