System mysteriously fails to boot

I’m not really sure where in the forum to post this.

I’ve been using Endeavour OS i3wm in MSI Alpha 17 laptop for about 8 months or so with no major issues. But a few days ago, when I turned on the laptop, it flashed the Lightdm welcome login screen for about 1 second and then went on to show a bunch of messages, none of which was apparently an error, and it hang there for a long while. I tried to open another terminal to reboot it but system wouldn’ t shutdown, it would wait for LightDM a long time and then the last message it gives me is:

[3780.728928] systemd-shutdown[1]: Waiting for process: 619 (Xorg)

. So I had to alt+sysreq+REISUB to reboot it.
Next time, I was very quick to type my password in the second the welcome screen flashed, so I went into the system.
But the next day, I wasn’t able to do that. I tried configuring LightDM for autologin but hasn’t worked yet.
It still flashed the welcome screen and then goes back to the black screen with messages.

IMAGES:

I checked the Xorg log and saw some errors, so I post them there.
Anyway, I’m not sure if it is just Xorg because I also get some strange PAM messages when I try to sudo in a second terminal, given that the first one, with the graphical session, does not give boot i3wm nor give me a command line. This could be related to me trying to setup autologin, although trying reverting it did no change, as described in a lower message, answering @joekamprad

There was no configuration change as far as I remember from my side. Only system changes that could have triggered this problem were updates through yay.

XORG LOG:

ENDEAVOUR OS (lspci+lsusb+journalctl logs) endeavouros log link:
https://clbin.com/ycAC8

EDIT: Added log link and images
EDIT2: Added last waiting for xorg process message and fixed typos.
EDIT3: fixed some semantics

Thanks!

The first thing I would try is switching to the LTS kernel to see if it is a kernel issue.

In addition to the X crashes, you have this:

abr 17 20:27:30 drac kernel: BUG: kernel NULL pointer dereference, address: 0000000000000010
2 Likes

Before the issue accursed?
If so revert to his…
Pam issue could be account blocked by to many wrong password attempt?

Possible to use LIVE ISO to fix it from arch-chroot.
Take a look in the EndeavourOS wiki for this.

Not really a BUG … looks more like some wrong configurations done if a mod could move this?
Hard for me only on smartphone…

Thanks!
the LightDM autologin configuration was NOT something I did before the issue accursed. I did it later trying to wokaround the main issue.

I edited the lightdm.conf and executed two commands:

sudo groupadd -r autologin 
sudo gpasswd -a username autologin

Now I tried to revert that with:

sudo groupdel autologin 
sudo gpasswd -d username autologin

And also edited lightdm.conf back to original (commented back two lines)

But PAM messages persist.

I did wait a long time waiting for system to shutdown and I noticed the last message I found was

[3780.728928] systemd-shutdown[1]: Waiting for process: 619 (Xorg)

EDIT: Also, I don’t think wrong configurations done were what caused the problem, because I haven’ t changed any configuration, only periodically updated system through yay.

EDIT2: I do have access to system console by switching terminals, I guess I could do everything that I could do in an arch-chroot directly in the system? I am using a Live ISO to write this posts on the forum though.

EDIT3: fixed typos and completed some info

thanks!
I tried updating to latest normal kernel in case it was a fixed bug today but problem persisted. I will try LTS later today. thanks!

I also confirmed today that Xorg is the process that won’ t shutdown and won’ t allow the system to shutdown so I think the problem is there. Maybe an AMD graphic driver that was updated carried a bug that is messing with Xorg?

As you say you had done some config before issue starts… afaik Autologin needs also setup in lightdm.conf.
And this could caused pam to fail too … possible…

1 Like

I’m sorry, I typed it wrong! I edited the reply now. I only tried to do the autologin, which consisted on editing lightdm.conf and executing groupadd and gpasswd commands, AFTER the problem arose. I was trying to find a workaround on it.

But now I reverted everything back (deleted autologin group and reverted lightdm.conf to otrginal) PAM messages still show, but also some other messages show, for example when I plug in a USB drive, I get messages on the command line. I probably have my terminal configured for extra verbosity or something, so that may explain the PAM messages?

OK. Tried linux-lts. Just installed it through yay and then grub gave me the option to boot on it. WOW so easy.
But problem persists the same with LTS

:frowning:

Doing a quick search, I’ve found this old thread on Arch forums about similar issue, the provided link on first answer suggest to downgrade xorg-server (and mesa).

thanks! I will check that out…
this is making me think this might be the moment to switch to sway (wayland)