System freezes at systemd during startup after installing NVIDIA drivers

This is really frustrating. I’m on an almost newly installed EndeavourOS/i3wm system after having this same issue on my previous installation, and it happened again. I installed the NVIDIA drivers on my system with prime and bumblebee, I reboot, and my system freezes at systemd, just before it’s supposed to show my login screen.

I have tried a lot of things. I tried chrooting to see if I could reinstall the drivers. Chrooting came with a whole suite of issues, like telling me certain files like /proc and /bin/bash didn’t exist or telling me I didn’t have permission to chroot. So I gave up on that.

I also tried adding nomodeset to grub, because I read somewhere that it could fix the issue, and that didn’t work either.

So, I’m stuck. Can anyone help me with this?

And no, I unfortunately can’t access a TTY to post my inxi output, because even that doesn’t work.

how did you install those drivers? If you downloaded them from the nvidia homepage, congrats, that’s why your system is broken.
this is the guide that should work. It uses the packages from the distro and Arch to install.

and freezes at systemd does not help at all with narrowing down the problem. The whole boot process is initialized by and done through systemd units. If you have quiet set as boot parameter, try removing that to get a boot log.

whats the chroot guide you followed?

I installed them through nvidia-inst. As for the chroot guide, I followed the arch-chroot page on the EndeavourOS wiki.

And when I say it freezes at systemd, I mean the thing that shows all of the daemons and services starting up after the bootloader screen. It finished starting everything up and then freezes.

You probably shouldn’t be using bumblebee. I don’t know what your hardware is but it’s probably newer and bumblebee is meant for way older hardware which isn’t supported by the newer drivers. We need to see the output of inxi -Ga We don’t even know if the drivers were actually loading. It may show them as NA. If it were me i would either boot and get into a tty and use nvidia-inst -n to revert to the open source nouveau drivers or arch-chroot to do it. Reboot and then check what inxi -Ga shows. I would also remove optimus-manager temporarily. Not sure but nvidia-inst may need to be installed if booting on the live ISO and arch-chroot. Then after i would boot and see if it loads the desktop again or get into tty. If you get it reverted to nouveau then i would install the nvidia drivers the manual way. I am also assuming that this is newer hardware?

Manual method:

sudo pacman -S nvidia nvidia-utils lib32-nvidia-libgl nvidia-settings

If you get the nvidia drivers installed and check that they are loading with inxi -Ga Then if so you could install optimus-manager

My GPU, I think, is either a GTX 1060 or 1080. Is that new enough to not use bumblebee?

Yes i would think so.