System freezes after a couple minutes of usage

My system keeps freezing after a couple minutes of usage on a fresh install of Endeavour. Most applications stop working, and entering any command in the terminal results in the message “command not found”. My task bar disappears and eventually my entire screen turns black. I do not know if this is a hardware or software failure. I have included the logs of journalctl --since=today. Please help!

Logs: https://sharetext.me/u9nvdidqd2

Specs:
OS: EndeavourOS Linux x86_64
Host: B450M DS3H
Kernel: 5.17.7-arch1-1
Packages: 995 (pacman)
Shell: bash 5.1.16
Resolution: 1920x1080, 1920x1080
DE: Plasma 5.24.5
WM: KWin
Terminal: konsole
CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz
GPU: AMD ATI Radeon RX 6600 XT

Welcome to :enos: forums!!
Could you use this wiki post to post logs and hardware information?

While you do what @sradjoker suggested, so we can better help you, I want to welcome your @baltaro to the :enos: forum. Enjoy!

My hardware: https://clbin.com/JmkE4
Boot log: https://clbin.com/U6gU1
Boot before that: https://clbin.com/H7Mby
System summary and boot log: https://clbin.com/G5Wab
Hope this helps! And thank you for welcoming me to the forums :smiley:

This is a terminal situation, fatal.
If the system never worked in a normal way, I would suggest you reinstall.

If you describe what you have changed in the system configuration, package installation, upgrading, removal etc, we might think of something.

A quick test to see if the user account is broken, or the complete system, is to create a new user and try to log in to that.

Does the Login Screen (Display Manager) work fine?

When I first got in I updated my mirrors and ran sudo pacman -Syu. Crashes started happening after I installed lutris. Specifically upon installing League of Legends did my system start to freeze. I later removed lutris and crashed one more time. I’ve now been using the system for about an hour and everything seems to be working alright.

It is suggested to reboot after your first package sync. After reboot, do whatever you like.

You can see pacman logs to find what was broken (usually some important packages are removed).

sed -n '/2022-05-16/p'  /var/log/pacman.log | grep -E "installed|removed|upgraded"
1 Like

Output of said command: https://clbin.com/617fA

Keep calm and pray! :rofl:

I guess it was a temporary leak somewhere… :laughing:

Thanks for the help @petsam, it seems like lutris is the main culprit. I installed it again to test and it indeed froze my whole system. Upon removing lutris everything returns to normal. Guess I’ll just refrain from using lutris for now!

Looks like my pc crashed again, thrice.
Here are the boot logs: https://clbin.com/zAZjH
The first time it happened after installing steam. The following crashes both happened a couple minutes after booting and using firefox. My entire system freezes and any commands I insert into the terminal are met with “command not found”. Kinda lost right now…

Something worth a try would be to check the healt of the disk and also perhaps run a filesystem check from within a live session. Just to eliminate possible causes.

Please show the PATH:

echo $PATH

I got met with this after I let my pc running during a freeze. Sorry I had to take it with my phone. I’ll see if I can boot again to try what you guys said.

Boot up your Live USB and run a filesystem check on your partitions:

https://wiki.archlinux.org/title/Fsck

Note: the partitions shouldn’t be mounted.

You could also use Gparted in the Live session to check the partitions. Right click on a partition and choose “Check”.

I am pretty sure OP means the grub rescue terminal :wink:

1 Like

I used GParted to check my partitions. Here are the results: https://clbin.com/5vZls

Can you boot into your system now?

If you can, check the health of your disks as well:

sudo smartctl -t short /dev/nvme0n1
sudo smartctl -t short /dev/sda
sudo smartctl -a /dev/nvme0n1

https://clbin.com/XfCxA

sudo smartctl -a /dev/sda

https://clbin.com/rGCwL

I’ll try booting again.

1 Like

I crashed again after about an hour of usage. It worked fine until then. It was different this time though. Instead of my system freezing up, I was instantly brought to the screen above.