System files updated ending in Segmentation fault

Updated my Cinnamon Desktop tonight with 5.8.10 kernel and latest Nvidia drivers and a few other files. Upon completion I received a Segmentation fault saying that the 'light display monitor ’ failed to install properly causing the Seg fault. Now the system just boots up showing this message. When I try the backup kernel in grub menu I get the same problem. System is toast. What do I need to do fix this issue? I hate as heck to re-install the whole system and all of the software I’ve got in place.

Rich :wink:

Which program did you use to update?

Can you boot to a TTY and update your system again, using pacman?

I used pacman to update the system. I don’t believe I can get into terminal to make any changes.


Have you tried it?

While booting, on the GRUB menu, press E.

You’ll see a bunch of code that looks like a shell script. Using the up and down arrow keys, find the line that starts with

linux   /boot/vmlinuz-linux ... 

go to the end of that line (press End), if the line is very long, your cursor may end up on the next line. Then type    Space    3 (just add that, " 3" to the end of the line that starts with ‘linux’, nothing more). For example, in my case (in your case it will be different), I would have something like

linux   /boot/vmlinuz-linux root=UUID=500a40b3-c412-4944-8f1d-9d8aee8a0a4b rw amd_iommu=on iommu=pt loglevel=3 nowatchdog

and I would change it to

linux   /boot/vmlinuz-linux root=UUID=500a40b3-c412-4944-8f1d-9d8aee8a0a4b rw amd_iommu=on iommu=pt loglevel=3 nowatchdog 3

Then press Ctrl+X, and wait a minute or two, you should boot to the TTY1, where you’ll be prompted to enter your username and password (while entering the password, there is no echo, so no characters like ****, just type in the password blindly and press Enter).

Then, while in the terminal, type:

sudo pacman -Syu

And when it updates:


If you cannot do that, where does it fail? What do you see on your screen?

If you cannot even get to a TTY, then you’ll need to boot from a live image and chroot to your install, I can guide you through that process, but first make sure you absolutely cannot get to a TTY without the live ISO. From the error message you’re describing, your issue seems to be with the Light Display Manager (not monitor, but close enough). That comes fairly late in the boot process, so you should be able to access the TTY.


I have run Cinnamon for a long time and it rarely has issues compared to other desktops. Sometimes i find it strange some of these issues. Lightdm doesn’t usually give any problem on Cinnamon. I wonder what would mess that up? :thinking: Obviously it probably has to do with his nvidia card updating. I wonder if he’s running just the nvidia? I run the nvidia-dkms as it seems to be way less problematic for nvidia drivers when updating.

1 Like

Yes, I running Nvidia as my main graphical driver. . . . can’t figure out why lightdm crashed and caused a segmentation fault. I was able to reinstall lightdm (3 files) and the system still came up with a segmentation fault and wouldn’t boot up. . . . Oh well. . . So I re-installed Manjaro 20.1 KDE on my desktop computer. ( I still have EndeavorOS on another desktop computer) and it updated without a hitch. I’ll try running both of them for now to see how things develop. I also gave up on Deepin (desktop) after several installs and crashes even though DeepinOS (china) came out with finalized v20. I tried to install that Iso but couldn’t get it to partition properly and install on my 3 terablyte gpt drive. It’s all been for fun and games for me. . . been distro hopping for over 20 years.

Rich :wink:

Did you choose nvidia when you installed Cinnamon from the online installer?

Edit: If you only installed the nvidia drivers next time i would install nvidia-dkms. This is recommended and it updated the kernel modules when there is an update.