System doesn't start after interrupted update

I’ve just ran a usual update however after downloading the packages and just after starting installing them, my laptop totally froze and I have manually shut it down

After booting it up again, all the boot process looks normal up until the point of “loading graphical interface” at which point it only shows underscore sign (which doesn’t blink) and stays like that forever.
I can’t switch to tty from there for some reason

I tried chrooting using liveusb and running the update in chroot but (after saying about db.lock file and me subsequently deleting the lock file to proceed) it only outputs “there’s nothing to do”

At this point I thought about manually reinstalling all the packages from my DE’s group (which in my case is KDE) however it didn’t solve the issue

I also tried running “e2fsck -p” on my drive but it just outputs “clean” and that’s it

My last backup is quite old (more than a month I think) so if there’s any way to fix the current state w/o rolling back to the backup, I’d like to try that first

Please tell me which logs to post if there is any need in them

Hi @Moshe_Yehudah

Post the output of the following commands to see where the problem is.

inxi -Fxxc0z | eos-sendlog
journalctl -k -b -0 | eos-sendlog
lsblk -o name,type,size,PTTYPE,FSTYPE

While I do, I just wanted to say that I was scrolling the journalctl and perhaps I found the culprit

Apr 13 19:50:24 Silent sddm-helper-start-x11user[822]: Failed to start “/usr/bin/X -nolisten tcp -background none -seat seat0 -noreset -keeptty -novtswitch -verbose 3 -auth /run/user/968/xauth_qtxcMd -displayfd 13 vt1”: Child process s>
Apr 13 19:50:24 Silent sddm-helper-start-x11user[822]: Running server: /usr/bin/X -nolisten tcp -background none -seat seat0 -noreset -keeptty -novtswitch -verbose 3 -auth /run/user/968/xauth_qtxcMd -displayfd 13 vt1
Apr 13 19:50:24 Silent sddm-helper-start-x11user[822]: Xauthority path: “/run/user/968/xauth_qtxcMd”

One alternative thing you could try in arch-chroot is look at file /var/log/pacman.log to see what are the latest updates, and try to update them again.

But before that I’d recommend backing up to an external drive any personal data you have on the machine.

In addition, for the future, look at the REISUB thread on this forum:
It may be really helpful when a machine gets stuck.


journalctl -k -b -0 produced --No entries–
And I couldn’t run eos-sendlog from chroot for some reason, so that’s that

Other two commands from my understanding could be run outside of chroot so them I ran outside of it with eos-sendlog

try only this one

journalctl -b -1

The boot errors are actually interesting

I tried reinstalling upgrades to the last packages,among which was xorg-server-common

After the updating though, pacman prints out “fatal library error, lookup self”

I’m going to try rebooting nonetheless, just to be certain
Upd: Yep, nothing has changed

I got it as a plain text file, but I can’t attach it here

It would be convenient with eos-sendlog, but it only works if internet is available.

Its weird that I have the internet while chrooted (because I can run pacman) but I can’t use eos-sendlog (it said smth about lacking graphics?)

Use option --no-yad with eos-sendlog.

I tried adding this option, afterwards I got prompted that “its going to public bin…etc”
I pressed Y and then:

Curl failed with code 6
Info: 0x0 failed, trying dpaste

And then it prompts again

PS: the error I was getting before adding this option is:
Authorization required, but no authorization protocol specified

(Yad:12): gtk-warning cannot open display: :0.0

curl code 6 means it cannot resolve remote host. So network is not working properly.

After deleting sddm, Ive managed to log in through TUI, but when trying to run startx I run into these errors:

Upd: I also tried to manually install xorg group to no avail

@manuel , @pycrk

Do you have any suggestions how should I proceed in light of the info I have on my “screenshot” above?

One idea is to backup all your personal data to an external drive, and then reinstall.
Sometimes trying to solve all hard-to-find problems will take much more time than a simple reinstall.

You also probably want to backup the list of packages you have currently installed. You can get the list e.g. like this:

pacman -Qqe > list-of-explicitly-installed-packages.txt
pacman -Qq > list-of-all-packages.txt

The first one is what you probably need, but the second one may be interesting if the first doesn’t include all you require.

1 Like

So reinstall it is then…oh well…

OK so in the end I used my 2-months old backup, laptop didnt boot, I chrooted from liveusb, updated it and now it works

1 Like

Nice work! Backups are really great.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.