System doesn't reboot or shutdown, just hangs instead

Hello! First of all, thank you to everyone involved in this project, even those who just help out on the forum - it’s so nice to see such a vibrant community.

I’m on the latest version of EndeavourOS, KDE; my hardware is MSI H170, i5-7500, GTX 1070 (nvidia drivers properly installed).

I have an issue that doesn’t really stop me from using my system, but it’s a tad annoying nonetheless: at boot the system is fine, grub is displayed and in some seconds i’m at the login page (sddm I believe? or whatever ships with default for KDE).

However, whenever I turn off my system or try to reboot, the screen blinks a few times from black to no-signal and then gets stuck onto:

Starting version 248.3-2-arch
/dev/sda2: recovering journal
/dev/sda2: clean, 320735/14622720 files, 9179973/58475544 blocks

which oddly looks like the text I see for a couple of seconds when booting. Anyway, after that, I have to hold my power button to actually turn off my PC.
What could cause this? Anything I can try to fix? Thanks in advance, have a great day!

Are you shutting down/restarting from terminal or from the desktop? Try ‘sudo shutdown now’ of ‘sudo shutdown now -r’ from terminal.

2 Likes

it also happens to me sometimes
but I just hold down the power button
but it does not happen that often
have also not found a solution
but for me it is not a big problem

1 Like

Additionally, to analyze the cause we need logs about the problem:

  sudo journalctl -b -1 | eos-sendlog
1 Like

Me too, I isolated the problem to two things, initially it was emacs, then I added a hand me down WD My Cloud and that hung me up as well. I wrote a script and use that to reboot/shut down.

1 Like

So, I did do that and no change, but out of curiosity I left it there, and out of the blue it did actually turn off after various minutes. Now the issue hasn’t presented itself anymore (maybe it still had to finish something from installation?? idk). I’ll keep on the lookout if it happens again after using specific software, i’m confused tho ?_?

2 Likes

If you use “poweroff” in a terminal it should shutdown the computer straight away, although if you have any open applications it may take a moment. Also “reboot” in a terminal should work fine. I use both because I always found that using the Plasma menu to shutdown or restart was unreliable.

2 Likes

First question that comes in my mind. Are you on X11 or Wayland session?

That’s a terrible idea, never do that. You’re just risking filesystem corruption for no good reason.

Use the Magic SysRQ button, instead.

7 Likes

x11! Wayland behaves pretty badly on my pc, at least last time I tried.

1 Like

Absolutely. My question was just to eliminate possible culprits.

Thank you! I will definitely set this up.

This unfortunately continues to be a problem, I’m using the default KDE Plasma and SDDM combo on a vanilla EOS setup (fully updated).

The solution was to modify the commands that the buttons execute, for KDE/SDDM this is inside a .conf file in /etc/sddm.conf.d directory.

The default halt and reboot actions were:

/usr/bin/systemctl halt
/usr/bin/systemctl reboot

Changing this to the following works:

/usr/bin/systemctl stop sddm && /usr/bin/systemctl poweroff
/usr/bin/systemctl stop sddm && /usr/bin/systemctl reboot

The problem in my instance at least seemed to be that SDDM was starting an X session right after being terminated for shutdown like explained in an older/patched GitHub issue. So stopping the SDDM service prior to shutoff worked. I checked the SDDM version and it’s 0.19.0-17 so the aforementioned issue should’ve been patched :thinking:

On an unrelated note, I’m facing further troubles with SDDM, it sometimes freezes on login. Hard lockup, can’t even drop to shell or magic sysrq my way out of it :confused:

EDIT

I continued to have issues with SDDM and login/logout, so I tried lightdm and also starting Plasma from .xinitrc. But even that had issues with a black Plasma screen on logging in sometimes, I then had to delete the .cache dir on each login and then start Plasma/X11. Everything’s working now :slight_smile: , reverted halt/reboot to the default commands as well.