System does not shutdown sometimes

Hi there,

Maybe someone could help me to troubleshoot this, if possibly?

Sometimes my system does not shutdown, after I click in the shutdown button. It goes to a black screen “forever”, and from that point I have to force it to shutdown (pressing the power button for a few seconds).

Is there some way to know what is causing this and maybe try to fix it?

I am running EOS with Gnome and 6.4.3 kernel. Below you can see some data from inxi:

CPU: quad core Intel Core i7-7700HQ (-MT MCP-)
speed/min/max: 1309/800/3800 MHz Kernel: 6.4.3-arch1-2 x86_64 Up: 4h 51m
Mem: 6.37/15.51 GiB (41.1%) Storage: 2.24 TiB (40.2% used) Procs: 310
Shell: Bash inxi: 3.3.28

Thanks in advance.

Can you include your motherboard and gpu info in your inxi?


  Type: Laptop System: Acer product: Predator G3-572 v: V1.22
    serial: <superuser required>
  Mobo: KBL model: Sienta_KLS v: V1.22 serial: <superuser required>
    UEFI: Insyde v: 1.22 date: 03/15/2019
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
    v: 535.54.03
  Device-3: Quanta HD Webcam driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel HD Graphics 630 (KBL

Has this been happening since the install or did it happen after an update? Have you tried the LTS kernel?

Well, I noticed it since I firstly installed EOS (around 3 weeks ago).

I have not tried the LTS kernel. Do you know what’s that EOS app to manage kernels? I remember to see something like this but don’t remember the name.

Maybe I can manage things through this app.

you can use the akm tool.
More info on this post:

Great! I’ll take a look. Thank you so much.

Might not be a fix, would just be interesting if we see any different behaviour.

Sure. Thank you. :slight_smile: