System crashes when sharing my screen

Hi, please help, my system crashes everytime I share my screen on Wayland, on Xorg it’s working fine, I can’t seem to get into TTY as well when it crashes, how do I get the important information from the logs about the crash?, I only know journalctl command.

Bei welcome on the purple :purple_circle: side :enos:
Not sure but I bet Wayland and screen sharing can indeed be buggy… easiest way is to use xorg session to not have such issue if possible

To provide better info check wiki:

1 Like

Hi Joe,

Yes, I’ve tried to use different display manager as well, and the issues still persists, for sure, while I can just switch to Xorg when I’m in the need of sharing my screen, but still if there is something I can do to fix this issue myself, I’ll be glad.

Here’s some information, I’ve read them, but I don’t think I can comprehend where the source of the issue is :slightly_smiling_face:

Welcome to the forum! :smile:

You have both Intel and Nvidia GPU.
Are you using both of them? If so, how do you switch from one to the other?
Can you also show the output of

pacman -Qs xf86-video
lspci -vnn | grep -P 'VGA|3D|Display'

inxi -Gaz to see what renderer is used please

using nvidia gnome on wayland… i bet it will have little issues… suggesting to use xorg session in this case… or noveau driver …

Thanks, Manuel!

I mainly use the Intel iGPU. I only use the Nvidia GPU for activities like playing games, usually I run them with the prime-run command.

Here they are :

Here’s the output of inxi -Gaz, Joe :

  Device-1: Intel Skylake GT2 [HD Graphics 520]
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-9
    process: Intel 14n built: 2015-16 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: ASUSTeK
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm
    non-free: 530.xx+ status: current (as of 2023-03)
    arch: Maxwell code: GMxxx process: TSMC 28nm
    built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:174e class-ID: 0302
  Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB
    driver: uvcvideo bus-ID: 1-6:5 chip-ID: 13d3:5a01
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland
    v: 23.1.1 compositor: gnome-shell v: 43.4 driver: X:
    loaded: intel,nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa dri: i965 gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x0696 built: 2015
    res: 1366x768 dpi: 112 gamma: 1.2
    size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1366x768
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel HD
    Graphics 520 (SKL GT2) direct-render: Yes

Ah, I assume my replies were flagged because I the 0x0 link?

fixed this… system security was unhappy with all the links you posted to fast :wink:

Apr 16 09:34:26 wired kernel: asus_wmi: fan_curve_get_factory_default (0x00110024) failed: -19
Apr 16 09:34:26 wired kernel: asus_wmi: fan_curve_get_factory_default (0x00110025) failed: -19

by any chance ther eis possible an update for the system firmware available?
Apr 16 09:34:20 wired kernel: DMI: ASUSTeK COMPUTER INC. VivoBook 14_ASUS Laptop X441UB/X441UB, BIOS X441UB.307 08/06/2019

Also, try uninstalling xf86-video-intel.

1 Like

If you’re talking about the BIOS, I believe the 307 version is already the latest.

Just did it!, but is it because ?

Note: Some (Debian & Ubuntu, Fedora, KDE) recommend not installing the xf86-video-intel driver, and instead falling back on the modesetting driver for Gen 4 and newer hardware. See [1], [2], Xorg#Installation, and modesetting(4). However, the modesetting driver can cause problems such as screen tearing and mouse jittering on XFCE, artifacts when switching virtual desktops in Chromium, and vsync jitter/video stutter in mpv.

I’ve always thought that Xorg needs it for the Intel iGPU.

only for very ancient pre gen 4 intel gpus…