System crash with Intel iRIS Xe Graphics

I assume so, I do a system-wide update every week

[ricklinux@eos-plasma ~]$ pacman -Qi mesa
Name            : mesa
Version         : 23.1.1-1
Description     : An open-source implementation of the OpenGL specification
Architecture    : x86_64
URL             : https://www.mesa3d.org/
Licenses        : custom
Groups          : None
Provides        : mesa-libgl  opengl-driver
Depends On      : libdrm  libelf  libglvnd  libunwind  libxdamage  libxshmfence
                  libxxf86vm  llvm-libs  lm_sensors  vulkan-icd-loader  wayland  zstd
                  libomxil-bellagio
Optional Deps   : libva-mesa-driver: for accelerated video playback [installed]
                  mesa-vdpau: for accelerated video playback [installed]
                  opengl-man-pages: for the OpenGL API man pages
Required By     : gst-plugins-base-libs  lib32-mesa  libglvnd  mpv  qt5-base  qt6-base
                  rocm-opencl-runtime  webkit2gtk  xf86-video-amdgpu  xf86-video-ati
                  xf86-video-vmware  xorg-xwayland
Optional For    : None
Conflicts With  : mesa-libgl
Replaces        : mesa-libgl
Installed Size  : 88.65 MiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Thu 25 May 2023 06:16:28 PM
Install Date    : Sun 28 May 2023 08:41:55 AM
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[ricklinux@eos-plasma ~]$ 

Yeah, almost as up to date as it can be

┌─[netsu@netsu-pc]─[~]
└──╼ $pacman -Qi mesa
Name            : mesa
Version         : 23.1.0-1
Description     : An open-source implementation of the OpenGL specification
Architecture    : x86_64
URL             : https://www.mesa3d.org/
Licenses        : custom
Groups          : None
Provides        : mesa-libgl  opengl-driver
Depends On      : libdrm  libelf  libglvnd  libunwind  libxdamage  libxshmfence  libxxf86vm  llvm-libs  lm_sensors
                  vulkan-icd-loader  wayland  zstd  libomxil-bellagio
Optional Deps   : libva-mesa-driver: for accelerated video playback
                  mesa-vdpau: for accelerated video playback
                  opengl-man-pages: for the OpenGL API man pages
Required By     : cogl  gst-plugins-base-libs  lib32-mesa  libglvnd  mpv  qemu-ui-opengl  qemu-vhost-user-gpu
                  qt5-base  qt6-base  retroarch  virglrenderer  webkit2gtk  zoom
Optional For    : None
Conflicts With  : mesa-libgl
Replaces        : mesa-libgl
Installed Size  : 88.64 MiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Sun 21 May 2023 15:28:37
Install Date    : Fri 26 May 2023 21:39:32
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Have you tried it with xf86-video-intel installed also to see if it crashes with the intel driver?

@ricklinux I did, it caused a bunch of weird glitches in my system, making it basically unusable, so I removed it

There’s a newer Mesa version 23.1.1-1 available here: https://archlinux.org/packages/extra/x86_64/mesa/
click the ‘download from mirror’ under Package Actions on the right of the page. Then run the following command from the directory you saved it to to install.

sudo pacman -U mesa-23.1.1-1-x86_64.pkg.tar.zst

Hello, sorry for the wait, I did update and get the latest mesa version, I have been experiencing a lot less crashes lately, but still do get them, I think the update did help tho. Does this mean that the solution is basically just to wait for newer updates? :broken_heart:

$ uname -a
Linux chengxx-xxxxxx 6.3.6-arch1-1 #1 SMP PREEMPT_DYNAMIC Mon, 05 Jun 2023 15:12:57 +0000 x86_64 GNU/Linux

$ inxi -G
Graphics: Device-1: Intel Alder Lake-S GT1 [UHD Graphics 710] driver: i915 v: kernel Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting dri: iris gpu: i915 resolution: 3840x2160~60Hz API: OpenGL v: 4.6 Mesa 23.1.1 renderer: Mesa Intel UHD Graphics 710 (ADL-S GT1)

My configuration is almost the same as yours:
kernel driver = i915 Display driver = iris (modesetting loaded) Gpu driver = i915 renderer = Mesa 23.1.1

Since your intel GT2 [Iris Xe Graphics] is newer than mine, i can not tell anything wrong with your configuration.
My only suggestion is the followings:

It may be better to reconfiure your Bios to boot only from USB and always to keep at least two arch OSs at hand in USBs.
The reason is simply that your hardware system has intel CPU and GPU and EOS does not install xf86-video-intel by default.

If your EOS has grub and mkinitcpio installed, you may try the followings, since these installs in the following make no harms to your system.

$ sudo pacman -S xf86-video-intel (no need, if installed)
$ sudo pacman -S intel-media-driver (no need, if installed)
$ sudo pacman -S intel-ucode (- - - > proiduce /boot/intel-ucode.img)

Check to see if /boot/intel-ucode.img exists, if not, install again.

sudo pacman -S linux-firmware (no need, if installed)

edit /etc/mkinitcpio.conf and change the line with ‘MODULES=’ to the followings:

      MODULES=" intel_agp i915 " 

edit /boot/grub/grub.cfg and add /boot/intel-ucode.img & ibt=off to the line beginning with initrd in the first menuentry as the followings:

echo ‘Loading initial ramdisk’
initrd /boot/intel-ucode.img /boot/initramfs-linux.img … ibt=off

build /etc/modprobe.d/i915.conf with content as the followings:

options i915 enable_guc=3
options i915 enable_fbc=1

build /etc/X11/xorg.conf.d/20-intel.conf with content as the followings:

Section “Device”
Identifier “Intel Graphics”
Driver “modesetting”
Option “DRI” “iris”
EndSection

$ sudo mkinitcpio -p linux
$ reboot’

Please use code tags around the output you post to make it easier to read.