System-config-printer won't run

Fresh, online, install using the Gemini iso. Added the LTS kernel, but not booting to it, and print support, XFCE4 DE. System-config-printer won’t load. From menu nothing happens, from terminal I get
Traceback (most recent call last): File "/usr/share/system-config-printer/", line 86, in <module> import cupshelpers ModuleNotFoundError: No module named 'cupshelpers'

Found the “included files” for system-config-printer and confirmed that cupshelpers is on my system.

# pacman -Syu and # pacman -Syyu (at different times), uninstall and reinstall of system-config-printers (including dependencies) have also been tried with the same result.

Someone please help with what next, or is this a case of the python update hasn’t fully propogated?


@nightshift can confirm this worked for me.

@joekamprad for some reason I did this (^ sys config solution) after reading your python 3.12 AUR package upgrade thread and rebuilding to 3.12. Not sure the sequence matters but I am superstitious when stuff actually works for me :slight_smile:

Thank you for the help, here and on telegram. The symlink did work. Not sure why all my searches didn’t bring up the linked post or the upstream issue, but, printer is setup now at least.

1 Like

only take care if on the next update some issue / warning happens you may need to remove the symlink again.

Yeah, i put a note on my desktop to remind me

1 Like