System ask for wifi passphrase every start

I use EndeavourOS since for month with Plasma (KDE) on a Asus notebook.
But since some days everytime i start the system, i have to enter the wifi passphrase. It seems to not be saved anymore.
I never use the KDE-Wallet (its not activated), so i think the wifi passphrase was saved in another way the last month.
Can someone tell me, if some changes are happened here?

…with witch network manager?

Well… the standard network manager, which is installed by EndeavourOS with Plasma. In htop its named “NetworkManager”,

Did you look at network connections? I’m not sure on kde but click on your wifi then click network connections, click on your wifi connection, setting icon, general and see if the box is checked all users may connect to this network. Not sure if that’s the issue.

This might help. Right click the network icon and choose Configure. Go to your wireless connection and then select the WiFi Security tab. See what it shows for storing the password.


1 Like

First, thank you for your help.
I tried this, but the next start the passphrase is away.

While i configured the networkmanager i see first time the message:
(in German): “Anmeldedaten für “Name of SSID of my wifi-router” konnten nicht bezogen werden.”
what means in english “Login data for “Name of SSID of my wifi-router” could not be obtained”
and in a second message:
“No agents were avaiable for this request”

Have you tried shutting down your router. Unplug it for a couple minutes and then restart it and wait until it’s fully up and synced. Then start your computer and see.

Yesterday i deleted the wifi profile (i should do this at first, i think) and connect completely new to my wifi. Until now i got no errors anymore and i dont have to enter the passphrase again.

It looks like solved. I dont exactly understand why, but it seems to be ok now.

Thank you all for your help. Great community here. I hope somedays i can help others here. :slight_smile:


Well guess what ? by posting your problem and getting it fixed you’re already helping others who have the same problem…if they search and end up here that is. :smiley: