"symbol "grub_debug_malloc" not found" after reinstalling Grub

I had the issue with booting to firmware after updating grub. After following The latest grub package update needs some manual intervention everything seems to work fine. However, upon reboot, I get the error “symbol “grub_debug_malloc” not found.” and a grub rescue prompt

I have tried downgrading grub and I get the same problem.

wel update it and do grub-install again…

check your bios efi order… eventual check bootorder with efibootmgr.

I had this happen to me once. I don’t remember exactly, but it had to do with my bios settings changed and were set to use csm or uefi and/or tpm or secure boot settings if I remember right for me.

Did you try reinstalling grub and updating the config from arch-chroot using the live ISO?

not really csm or legacy that has to do something differnce…

in bios you can have some bootorder too…try to change that

edit: disable secureboot tpm is always good, csm is no go :slight_smile:

I also had the grub_debug_malloc error.
My issue turned out to be that I was booting into my EFI system using the EndeavourOS USB ISO in Legacy mode instead of UEFI mode.
After booting using UEFI mode the instructions for reinstalling Grub made perfect sense for me, although an extra boot option was created in my BIOS called EndeavourOS-grub I think.
Anyway the new boot option was the one that I then needed to use to avoid the grub_debug_malloc error.