"Switching Sound Cards"

I have been trying to switch between Nvidia sound and motherboard embedded sound. I’m using pipewire and easyeffects. Both working fine with nvidia sound. But would be good to know how to switch them. I have installed the plasma widget “Audio Device Switcher”, after trying with pavucontrol. No luck so far but it does show activity in the volume icon in the system tray when I switch to 2nd card. Here’s a little info:

“arecord -l”

card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 2: ALC892 Alt Analog [ALC892 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0```

"cat /proc/asound/cards"

```0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfc080000 irq 57
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfc400000 irq 59``

[audio|511x500](upload://sqYy2Izslt81Su20I99daWZVB56.png)

With nvidia : sound working fine.
![Matisse|511x500](upload://uHW6wFX9KhDyyrv73l065bQZuwf.png)

With starship/matisse : activity but no sound.
This is not a great problem as I said b4 one works, but if you one wants to learn these things, you ask those that know!

```Audio:
  Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s
    lanes: 16 bus-ID: 26:00.1 chip-ID: 10de:1aeb
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: speed: 16 GT/s lanes: 16 bus-ID: 28:00.4 chip-ID: 1022:1487
  Sound Server-1: ALSA v: k5.17.3-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes```

Thanking you, 
Dave

Are you able to change it with alsamixer using F6?

alsamixer

Edit: It may or may not work as I’m not sure where to change it since it has alsa and pipewire-pulse

Edit2: Not sure if setting it here works either. You’ll have to try it.

https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card

Thanks, Tried that. Brother back from holidays soon, he’s the whiz at this stuff. Like I say they are both working, only one has sound output. Maybe they need diff cable setup. Definately not my forte!
Would just like to say, I love endeavouros, It has come a long way, in such a short time. I would say this is the most cordial forum out there. Keep up the good work :sunglasses:
Thanks as always
Dave

Maybe you can switch them with the Audio icon in the panel. With KDE Plasma, here is what I get.

Audio

You can only select one or the other, but not both.

HTH

Pudge

Thanks Pudge.
I have tried this before, as I said earlier it;s active as you can see here:


But no sound out of speakers.
I’m a noob when it comes to sound cords.
My partner takes care of that! :grin:

1 Like

New surround with nvidia hdmi sounds good. Still working on that starship/matisse card!