Switch off wayland for xorg

I want to switch back to xorg, having issues trying to get a proper use of KDE even with the wayland packages. Also the Desktop manager seem to also struggle with it. I put sddm and just present with a black screen. I am trying to stabilize my desktop and I think xorg would do a great job. Please let me know how can I get back to it.

I tried looking online but my system doesnt have /etc/gdm/ directory so my guess is that sddm will have a different way to configure.

i cant tell, currently Xorg is standard as for KDE is the same.

for kde you need to install plasma-wayland-session , its a option that enables the wayland. wayland is for now just a layer above Xorg. sddm is wayland compatible but does not put wayland on the first rank.

as for gnome is different, it enables standard wayland on purpose for feedback.

what tells journalctl -f or journalctl -xe ? probably some videocard configuration.

1 Like

To add to what has already been said:
https://wiki.archlinux.org/index.php/Weston
https://wiki.archlinux.org/index.php/Wayland

IMO Wayland is not ready for prime-time use, especially with KDE/Plasma. Someday maybe, but for now the safest bet is Xorg.

2 Likes

How can I be in xorg only?

Can’t agree, I’m using sway (i3 wayland implementation) in both my job PC and home laptop, both with xorg-server-xwayland, and so far (4 months I think) everything works just as it’s meant to. My job PC is miision-crital for me, and I have almost full trust in sway stability.
Actually there is only single one app that isn’t working well, and that’s pepper-flash (I’m not sure whether it’s kvm redirection issue or pepper itself).

For anyone on i3 I can fully reommend transferring to wayland with sway. Actually sway is even better imho :slight_smile:

@Jzarecta I don’t know the state of your installed system, so I suggest you start by searching this forum for waylamd and xorg. And read the following to get a better understanding of xorg and possible problems with wayland and KDE.

From the Arch Wiki:
https://wiki.archlinux.org/index.php/Xinit
https://wiki.archlinux.org/index.php/Xorg

Hello @patryk, I’m glad Wayland is working for you on I3 and your hardware, but for many of us who are using a different DE or have different hardware, Wayland didn’t and doesn’t work as expected. But for many others like yourself it does. It’s great to have choices when they work.

1 Like

but can for the record also this : https://wiki.archlinux.org/index.php/SDDM#Blank_screen_with_cursor,_but_no_greeter_shows as i send the link on [TG ]

blackscreen can every source to outsource it is atleast have some information disk / boot messages or the journals like https://endeavouros.com/docs/forum/how-to-include-systemlogs-in-your-post/

1 Like

interesting read on this:
https://community.kde.org/KWin/Wayland

@Jzarecta it sounds like you tried to use wayland session before and now want to switch back?
Or is it that you think only the issue is caused by the reason sddm tries to start a wayland session?

Please provide journal logs e.t.c. to let us help you solve the issue.

No, wayland was already there with the default installation, I actually had only plasma-session-xorg only at the start. I tried to get rid of xorg-wayland but no luck.

what gives you:

pacman -Qs wayland

?

but you can not uninstall all wayland stuff complete as it is already integrated in the framework of xorg and others. wayland itself is a dependency for mesa and you can’t remove mesa …

Playing like this will lead you to a non working system.

Make clear what is your issue by providing logs and hardware information, then someone can help you with hints and help.

i am off till that…

Wayland is installed in every linux distri, cascade remove wayland end in a nonworking system, kde brings standard plasma-session, theoretical yiu can start ker manual in wayland but to do auto you need plasma-session-wayland with the session point to wayland and you have to select in sddm. Dont blame wayland it is not autostarted in kde and xfce cannot use wayland currently.

I get the following:

$ pacman -Qs wayland
local/egl-wayland 1.1.4-2
    EGLStream-based Wayland external platform
local/kwayland 5.64.0-1 (kf5)
    Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.17.4-1 (plasma)
    Provides integration plugins for various KDE frameworks for the wayland windowing system
local/libva 2.5.0-1
    Video Acceleration (VA) API for Linux
local/plasma-wayland-session 5.17.4-1
    Plasma Wayland session
local/qt5-wayland 5.13.2-1 (qt qt5)
    Provides APIs for Wayland
local/sddm 0.18.1-1
    QML based X11 and Wayland display manager
local/wayland 1.17.0-1
    A computer display server protocol
local/wayland-protocols 1.18-1
    Specifications of extended Wayland protocols
local/xorg-server-xwayland 1.20.6-1 (xorg)
    run X clients under wayland

And what is the output of df -h , you are focussing on wayland, but wayland is not the standard also with kde it is not the standard , in gnome-hell is wayland is standard gdm i dont know … df -h journalctl -p or -xe i dont know… In a pastbin service

plasma-wayland-session
Can be removed it is not required by anything.
And then there is no Wayland session anymore to start :wink:

I dont have gnome on my box.

was just a exampjle plasma-wayland-session removal is enough but wayland is in every distro as depency but is sleeping thats i wanna say only gnome has enabled standard. information is priceless outside that suspicion of wyalnd is welcome, focussing on a single issue would not fix a thing.

plasma-wayland-session
Can be removed it is not required by anything.
And then there is no Wayland session anymore to start

I tried to do that but couldnt start regular plasma, I also tried just starting plasma-xorg-session. I have both packages.

how do you know that it is an issue with wayland then?

https://endeavouros.com/docs/forum/how-to-include-systemlogs-in-your-post/