Sway WM waybar idle_inhibitor button not working properly

In my Waybar, I have enabled the Waybar idle inhibitor by clicking ‘active’. Everything works fine. However, after clicking ‘active’, I reload the Sway ($mod+Shift+c), and then it automatically deactivates. Why is that happening? pls help me to solve this problem and other question is how to disable swayidle . thankyou

Why do you reload sway? I don’t think that is meant to be persisted

then should i use with out reloading . because when i reload i feel its refreshing.

also can you say how to disable swayidle via terminal commands

I’m afraid I don’t know… why isn’t the waybar button enough?

the button is fine . but i am asking manually execute from terminal

It’s a normal process you can stop with pkill or similar…but this sounds like an XY problem. What are you actually trying to accomplish?

thanks for the reply mate . now everything fine .