Sway stuck on black screen, can only use alt+ctrl+f2 to get into console

Bspwm was giving me a lot of problems, I wasn’t even able to get into a terminal on my laptop, so I switched to the Sway edition because I heard really good things. However, the only thing I’m able to do is get into a console, not a terminal. I’m not sure if this is normal for sway, but there isn’t even a desktop. I tried installing i3 on my Kubuntu distro a while ago and what worked perfectly… so I don’t know why sway is doing this. I want to stick to endeavour, but I am having problems on all 3 installs that I’ve tried. Being i3, Bspwm, and Sway. I really want to fix sway because that looks like a great lightweight WM which is perfect for my older laptop.

Any help would be amazing, I already looked up this problem on the forum and google and none of the answers seemed to help. Thanks I’m advance for helping me out!

1 Like

If u get into console and type sway what will happen?

Are u using NVIDA?

Laptop has an intel iGPU, no Nvidia

I tried that the first time and it worked, but the second time after a reboot it asks for a login, I use the same one and it fails. I made sure a few times, the same login failed time and time again. Now I’m stuck out of my OS, can’t boot. I can’t enter sway without logging in either…

That’s my problem now…

So when you are in tty login does not work?

You log in with tty and work ? or you log in with LDM and say wrong password/usr?

you use metal or VM?

1 Like

This can be caused by a lot of different things… the first bet would be an issue getting files from GitHub, so you are missing some steps from setup and config files (they will be fetched from GitHub directly on install)

  • On install do you unselect anything on the packages screen?
  • do you update mirrors before starting install? Could be a mirror that failed to get packages.
    (if there are only a little number of mirrors in your country try adding some from countries near by)
1 Like