Sway fails to access with terminal cmd

Running inxi -Faz fails to access and run the command. Not sure what changed here. Is the same on a fresh install.

1 Like

Can you show the command and the possible output?

It did this on a current install and i reinstalled it with the latest ISO and is the same so something changed with updates maybe?

inxi -Faz

1 Like

Is logging in not working as well as inxi?

No i was already logged in and this box comes back up instead when i run the command from the terminal.

Edit: It’s strange because inxi works. It seems to happen with the small a is added added?

Edit2: I can run

inxi -Aa

inxi -a

inxi -A

I can run inxi -F but as soon as i add an a that’s what comes up?

1 Like

Inxi was upgraded 2 days ago.
What happens if you downgrade inxi?

1 Like

This is fresh install so i I have to find the inxi version and downgrade it another way.

Edit: How do i find the older version if it’s not a package cache?

Use program downgrade.
It gives you a list of older versions to choose. They are archived to the internet.

But it is a fresh install and only shows current version?

Edit:

[ricklinux@rick-ms7c37 ~]$ sudo downgrade inxi
[sudo] password for ricklinux: 
loading packages...
warning: inxi-3.3.15.1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (1)  Old Version  New Version  Net Change

inxi         3.3.15.1-1   3.3.15.1-1     0.00 MiB

Total Installed Size:  1.07 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 

It should show many old versions even if you have never installed them.

Well it isn’t showing any other than installed?

Does EnOS keep an archive of older packages?
inxi is not in Arch repos (and consequently not in ALA) so that is probably why downgrade comes up empty handed.

I noticed that too.

So won’t that explain why downgrade is not showing older versions?
That was the point I tried to make :wink:

Sorry Rick, I totally forgot inxi is from our repo. We don’t have archives.

No problem. I had reinstalled Sway trying to figure out if it was a problem that happened from the new ISO but obviously it isn’t. I had the same issue on the current install and and when i installed the new ISO.

Edit: It only seems to do this when using inxi -Faz

Edit2: If i drop the small a it doesn’t do it. Yet i can use the small a in other commands.

BTW, we do have some older packages archived, but it is not under real maintenance.
For example, an older inxi is here:
https://github.com/endeavouros-team/archive/releases/download/packages/inxi-3.3.11.1-1-any.pkg.tar.zst

Okay i downgraded it and it still does the same thing.

[ricklinux@rick-ms7c37 ~]$ pacman -Qi inxi
Name            : inxi
Version         : 3.3.11.1-1
Description     : Full featured CLI system information tool
Architecture    : any
URL             : https://smxi.org/docs/inxi.htm
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : coreutils  pciutils  perl  procps-ng
Optional Deps   : bluez-tools: bt-adapter: -E bluetooth data (if no hciconfig)
                  bluez-utils-compat: hciconfig: -E bluetooth HCI data
                  bind: -i wlan IP [installed]
                  dmidecode: inxi -M if no sys machine data [installed]
                  file: inxi -o unmounted file system [installed]
                  freeipmi: ipmi-sensors: -s IPMI sensors
                  hddtemp: inxi -Dx show hdd temp
                  iproute2: inxi -i ip lan [installed]
                  ipmitool: -s IPMI sensors
                  kmod: inxi -Ax,-Nx module version [installed]
                  lm_sensors: inxi -s sensors output [installed]
                  mesa-utils: inxi -G glx info [installed]
                  net-tools: inxi -i ip lan-deprecated
                  perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)
                  perl-cpanel-json-xs: --output json - required for export
                  perl-json-xs: --output json - required for export (legacy)
                  perl-xml-dumper: --output xml - Crude and raw
                  systemd-sysvcompat: inxi -I runlevel [installed]
                  sudo: inxi -Dx hddtemp-user;-o file-user [installed]
                  tree: --debugger 20,21 /sys tree
                  upower: -sx attached device battery info [installed]
                  usbutils: inxi -A usb audio;-N usb networking [installed]
                  wmctrl: -S active window manager (not all wm)
                  xorg-xdpyinfo: inxi -G multi screen resolution [installed]
                  xorg-xprop: inxi -S desktop data [installed]
                  xorg-xrandr: inxi -G single screen resolution [installed]
Required By     : None
Optional For    : eos-log-tool
Conflicts With  : None
Replaces        : None
Installed Size  : 993.19 KiB
Packager        : EndeavourOS <info@endeavouros.com>
Build Date      : Fri 17 Dec 2021 12:27:09 PM
Install Date    : Mon 11 Apr 2022 10:21:58 AM
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

[ricklinux@rick-ms7c37 ~]$ 

Very strange? I used inxi -Fa this time

I remember the eos-log-tool had some problems with inxi earlier, and I haven’t tested that lately.
Inxi did something strange with terminal I/O at the time, but later they fixed it. Maybe it is not working well now?

I don’t know but I can use the small a in the command except after an F?