Sway community edition, no video after install

Just did a fresh install of Atlantis + Sway Community. No video.

A quick troubleshoot shows incorrect permissions on a lot of stuff in /dev…

  • No access to /dev/tty*
  • No access to /dev/dri/*
  • No access to /dev/input/*

The access issue seems to be a combination of the default user not being in correct groups (input, video, etc), and the directories not having the correct permissions (no group write access to /dev/tty*, /dev/dri/*, etc.

Anyone see a similar issue?

Welcome to EnOS’ forum @kallisti5!

Striking similarity!

lol. Some avatar generator circa 10 years ago.

1 Like

I don’t think it’s needed to be in those groups for a normal user. When I install sway and create a user in arch I only put them into the wheel group for sudo. The rest is never needed. So I doubt it’s a permission issue. But that’s just my guess. I sadly have no idea how to go on about this issue, though.

1 Like

I think maybe it’s related to the default installed display manager (lightdm) trying to do x11 + sway?

Here’s the logs I keep getting pointed to:

kallisti5 is my local user account created via the installer. Missing input, video, render which I guess are needed for X11.

sway is wayland though as I understand it… so that feels wrong from the get-go

Is this a VM installation? If yes, did you enable 3D acceleration?

I don’t understand the connection between incorrect permissions and the display manager.

And what is the context for

with a lot of VMWare entries?

qemu running under linux using the standard virtio gpu device.

qemu-system-x86_64 --enable-kvm -m 8G -hda endevor.qcow2 -device virtio-gpu

at this point I think multiple bugs are happening.

  1. Default lightdm trying to start sway under x11
  2. sway has some bugs running on virtual hardware
1 Like

thought eos sway community edition use Ly as default … Lightdm give problem.

4 Likes

Just to see if the problem is the desktop manager’s greeter, install sddm, disable lightdm, and enable sddm. If it works, you can either stick with sddm or concentrate on trouble shooting lightdm.

$ sudo pacman -S sddm
$ sudo systemctl disable lightdm.service
$ sudo systemctl enable sddm
$ systemctl reboot

Pudge

2 Likes

On the GitHub report you say using default configuration… But you installed the Community Edition or try starting sway without the custom config?
The C_E would have LY enabled per default.