Suspend/Hibernation Non-functional on Acer Aspire 3 laptop

Hello all,

I’ve been having an issue where suspending or hibernating the system results in the screen turning off, but the laptop does not actually sleep/hibernate. The power light stays blue rather than flashing orange as it is supposed to when the computer is in a sleep state, and I can clearly hear the fans still running. Once the computer is in this state, nothing will wake it up, and the only was to get out of it that I have found is to hard reboot it.

This issue happens when I try to suspend/hibernate in any DE/WM I have installed, same with the buttons in the power menu on the lightdm login screen and running commands like systemctl suspend or s2mem.

When I first had this issue, I realized I had not set up any swap while installing so I set up a swap file with the appropriate amount of space following the arch wiki instructions, but it has not changed anything as far as I can tell.

Because I had a spare external SSD, I installed EOS on that to see if the same issue is there even if I select swap with hibernate in the installer, and sure enough it still is an issue.

The only place where suspending works properly is in the USB live environment. When I click the suspend button in it it suspends the machine perfectly.

The specific model of the laptop is the Aspire 3 A315-21-95KF.

Any and all help would be greatly appreciated.

Same problem on an Acer Aspire A315-22

this is the first time I’ve installed linux so could also use some help

I actually swapped off Endeavour for Archcraft because I was out of ideas and couldn’t find anything on my issue, but I’m 99.99% sure that the issue for us is due to recent kernels updates, not any particular distro.

I can’t believe I didn’t think of this before, but all I did to fix the issue was downgrade the kernel to the kernel version that the live installer had (because I was able to suspend from the live installer). That entirely fixed it for me. I personally downgraded to 5.14.9-arch2-1 because that was the kernel the Archcraft live installer had, but if you can suspend from the Endeavour live installer on your computer as I would just downgrade to the kernel that it is running.

To get your kernel version in the live installer pop open a terminal and run

uname -r

and it should give you the kernel version the installer is running. You should try downgrading to this version.

The way I downgraded my kernel was using the downgrade package from the AUR. I’m not sure if it is preinstalled on Endeavour, but regardless get it and run a simple

sudo downgrade linux


sudo downgrade linux-lts

Depending on if you are booting with the LTS kernel. (iirc, linux-lts in the kernel endeavouros boots to by default if you don’t touch anything and is the first option on the list in grub)

When you run this command, you should get a list of old versions of the kernel. Pick the one that lines up with the one in the live installer, and once you’ve installed it reboot and see if you can suspend.

Before you suspend, make sure to run uname -r again to be sure that the kernel downgrade worked/you picked the right option in grub.

Try this out and get back to me, I’ll try to keep helping you out as much as I can.

Perhaps just install/tick the lts kernel along the regular kernel upon install to try an earlier kernel.

Also some useful infos

Which DE are you using? I assume you set in system settings, power, battery suspend or hibernate upon closed lid…?

Also what filesystem did you install? More system infos would help.

yea downgrading kernel is not a real solution as it will break packages/drivers one day soon.
using LTS should be to the test at first.
And for hibernation you need to have resume setup properly.

Suspend was fixed by downgrading to the latest kernel 5.15, but hibernate still caused an infinite hang. It might be problematic because of the encrypted btfrs swap partition, but I used the setup wiki for that purpose.

At the moment suspend is fine, I haven’t investigated hibernate further.