Support for fingerprint reader

I have an Asus F571GTif that helps. How can I get the name of my fingerprint reader?

as i do ask before already lsusb or lspci should show it also if there is no driver available for it…


This do not look like conventional device… and Asus webside and all reviews not showing a device name…
It will be ELAN tech device as i can see here:

HI, i’ve the same problem.
when I was using Manjaro I tried the archwiki tutorial and despite the help of the administrators my fingerprint reader never worked. I also tried when I was using Arcolinux but it was the same … Do you think you will be able to help me operate this fingerprint reader for the first time?

lspci
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation 6th-10th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630]
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #1 (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller (rev 10)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
00:1d.5 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #14 (rev f0)
00:1d.6 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #15 (rev f0)
00:1e.0 Communication controller: Intel Corporation Cannon Lake PCH Serial IO UART Host Controller (rev 10)
00:1f.0 ISA bridge: Intel Corporation HM470 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10fa (rev a1)
06:00.0 Non-Volatile memory controller: Micron Technology Inc Device 5410 (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 25)
08:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1c7a:0570 LighTuning Technology Inc. EgisTec Touch Fingerprint Sensor
Bus 001 Device 002: ID 04f2:b64f Chicony Electronics Co., Ltd HD User Facing
Bus 001 Device 004: ID 8087:0029 Intel Corp. AX200 Bluetooth
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I see that there is an aur package with patch for your device, maybe you can try it
https://aur.archlinux.org/packages/libfprint-acer-swift-1-git/

xinput --list --short
can give ELAN device id, which is clubbed with mouse id for these ASUS devices, and recheck on SPI devices section at https://fprint.freedesktop.org/supported-devices.html

V1.90+ rewrites of libfprint has new API to support these sensors, but I couldn’t be able to figure out how to make the recent libfprint release work with fingerprint-gui. or I don’t know what else can I do with just recent releases of libfprint and fprintd.

maybe the gui package will port when V2.0 releases or hopefully one of us could write a new one by then.

Hi @ceph
it’s cool if it can work. but before I do a backup of my system but with timeshift the images made do not work unlike Manjaro or Arcolinux. I need to learn better how to save with EndeavorOs.
Is this tutorial still relevant? ArchLinux Fingerprint

I don’t think gui package works directly with v1.90+ libfprint version as gui package has a dependency of libfprint-1 and editing PKGBUILD won’t work directly as the API also changed, but I read gnome display manager would provide the gui once these pacakges are available.
else fprintd-enroll could work as per the instructions at https://wiki.archlinux.org/title/Fprint

As of now enrolling my asus ELAN sensor results in
Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available
I will tinker more and update my status

I will still try on my other computer what you say because you are probably more qualified than me :wink:

Here is the update after following arch wiki:
As mentioned earlier, the latest merges fortunately added my ELAN (embedded) sensor support to libfprint

If others are looking to add their fingerprint, first check the supported devices list

  • My device id is 04F3:30C6 and I installed fprintd and libfprint packages.
  • Enrolled right index fingerprint using fprintd-enroll, you can set up other fingers too as per the wiki
  • You can verify your added finger with fprintd-verify
  • Added below entries to the start of the files /etc/pam.d/{sudo, system-local-login, kde, sddm}. You can ignore the first line if you want to always trigger fp scan first. Read the wiki for more details.
auth		sufficient  	pam_unix.so try_first_pass likeauth nullok
auth		sufficient  	pam_fprintd.so

while sudo authentication works with fingerprint so far, the kde/sddm login screen is never triggering fingerprint scan after first enter. More things to try now…

Edit: Yay!! it finally started working after I removed /etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop.

Edit 2.0: Oops! looks like we bumped a really old thread. Sorry.

mine is not listed to supported list .

Bus 003 Device 004: ID 06cb:00da Synaptics, Inc.

https://fprint.freedesktop.org/supported-devices.html

Edit:

1 Like

I followed the instructions, the fingerprint authentication works for example in terminal when it’s neaded(sudo pacman -Syu etc.), but on system start, it doesn’t give me option to fingerprint login, just by entering the password. Btw I’m on gnome, wayland.

you need to set up pam for GDM … i got this working with lightdm was easy I remember…

this is what i used for lightdm:

Dont know about that, cause there’s no one file called gdm.
But i installed fprintd, libfprint, and added fingerprint in Settings->Users->Fingerprint Login.

https://wiki.archlinux.org/title/Fprint
Also a nice tutorial on the subject.

Please let me know if am missing anything as I am not able to configure the fingerprint in KDE 5.24 as I don’t have option to setup under Settings–>Users

lsusb | grep Fingerprint ─╯
Bus 001 Device 004: ID 27c6:5385 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader

inxi -M ─╯
Machine:
Type: Laptop System: Dell product: XPS 13 9370 v: N/A
serial:
Mobo: Dell model: 0F6P3V v: A00 serial: UEFI: Dell
v: 1.18.0 date: 12/09/2021

Update: I am not sure if this fingerprint sensor in this laptop is supported as I did not see it in the list of supported devices…may be out of luck here…

It is listed in the unsupported devices.

|27c6:5385|Dell XPS 13 9370|USB dumps in libfprint#43

@ricklinux …thanks for the quick response…appreciate it