Support disk for asus z97-a

I am running an Asus z97-a motherboard but did not receive the support disk. I have it now and opened it in Bin tried to run ASSETUP.exe but can’t figure out to open a windows exe file in Arch linux. Any thoughts on this problem will be appreciated. I’d like to upgrade the bios and firmware.

This package is in the AUR.

Ricklinux you are so quick to answer.

I’m not sure if it works but that package is dvgrab Is that what you are looking for?

You can’t run a Windows exe file on Linux.

Ok, no windows support disk, but I am looking to install . Thanks as always.

Do you have Windows installed?

No, sir.

I’m not following? What you originally posted pointed to that package dvgrab? What is it that you are wanting to do?

Both actually. Install DVgrab on Arch linux and update my bios and firmware on the asus board which has Arch on it.

There is only one Bios update file i see for that board? If this is what you want to do?

Version 3503 Beta Version 2018/04/26

This was a Beta version and looks like the last version put out. You can update your Bios by downloading the new Bios file and extracting the files and copy to a usb drive. Then you boot and enter the Bios screen where you can use the EZ update tool to update the Bios.

The package dvgrab is in the AUR.

[ricklinux@eos-kde ~]$ yay -Ss dvgrab
community/dvgrab 3.5-9 (124.8 KiB 353.1 KiB) 
    Saves audio and video data from an IEEE (FireWire) digital source
[ricklinux@eos-kde ~]$ 

You can install it with yay

yay -S dvgrab

Edit: You’ll have to go to the motherboard site and download the latest Bios update file if you want to update the Bios.

You can download the manual if you like or look at it online which shows how to update the Bios.

yes I saw that bios upgrade on the Asus site. The beta thing sort of second guessed it for me… Funny how they dropped the ball on that model. Promised things that never got implemented.

Well it’s up to you if you want to try it. You can usually go back to the previous version if there is a problem with it. They probably will never put out any more updates for that board. Usually it’s updates for a couple years if you’re lucky.

I’ll back up the original and give it a try. Thanks again.

Hopefully the package dvgrab from the AUR builds and installs successfully.

Hopefully…

Dvgrab works like a charm!

Excellent!

Is it just me or does this thread make no sense? It starts from a question about a Windows recovery medium then moving onto how to upgrade a BIOS before being solved by some software for saving media from a Firewire source? :exploding_head:

Oh, wait - the OP completely re–wrote the original post - what is going on? :confounded: