Superkey Behaviour Changed since 43

In the past superkey has always taken focus in the Type to search field so I can just type. I don’t recall changing anything, but now Superkey opens the screen, but the Type to Search field is not in focus.

So now I have to go to the mouse and click the search field before I can type. I checked the keyboard shortcuts and I see the Launch options are greyed out. Please help.

It still does on my end.

Look for the usual suspects: some extensions?


Here is the strange thing: it has just fixed itself since I created this post.
It’s nice to have my superkey again, but I didn’t do anything to get it working again. So it fixes itself and goes faulty intermittently. This never happened under Gnome 42 and that is the only change I have made.
It also occasionally, adds extra characters in search. e.g. I type settings and I get sseeeeettingssss. It a USB Logitech keyboard, which I only had a month. When it does this weird behaviour it’s the same with the laptop keyboard. Then I reboot and the problem is solved for a few days. Strange huh. How to troubleshoot that?


I bet they have an extension to fix that keyboard behaviour :rocket:

It’s broken…it has a :bug:

1 Like

The bug just fixed itself

1 Like

Or more likely the conditions that cause it have not been revealed yet. Why I am always chasing projects when they dismiss it with “Not happening to me”.

1 Like

Well it comes and goes, but it’s a real thing.
Pressing the superkey no longer gives focus to the search box, even though it’s configured that way; so I have to the box and then type. On occasions it starts stuttering: I type pika in the search box and it goes ppiiiikka
Yes it needs work. Yes it will get there. Yes I will wait.

We have a term for that, “Verschlimmbesserung”, meaning trying to improve while making things worse. This has been a constant with Gnome and KDE, as far as I’m concerned…

In English this is disimprovement, worsening. I can only say one thing. This is much worse on Windows. :rofl:


Unfortunately, I agree with you.

I solved it. ArcMenu is a system extension and is only partly Gnome 43-ready, so I disabled the extension.

The Left Superkey is in General Settings so it can still run independent of the ArcMenu system extension.

ArcMenu no longer appears on the top menu bar which was already too busy

So as this is a workaround to the thread’s title, l will close the thread and move onto the next exciting Gnome 43 bug.

It’s not really a work around. A bad extension caused an issue. It’s not a gnome problem. It’s an Arcmenu problem. Please report the issue to the extension manager.

I checked it. After pressing the super key, if I start typing something, the search box appears. I also have quite a few Gnome extensions installed, but none of them affect this operation.

ArcMenu is still on version 42, so I think that is the extension causing it. I will just keep three finger swipe down until 43 is supported.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.