Sudo umount /dev/ssd1 - target is busy

I was following tutorial to make a usb stick linux extension (so i can put timeshift snapshot in it).
https://www.tutorialspoint.com/how-to-mount-usb-drive-in-a-linux-system

but sudo umount /dev/ssd1 result a denied action with reason “target is busy”

That means you have it open somewhere.

Make sure any files you opened from there have been closed, that the file manager isn’t looking at that location and you don’t have any terminals that have cd’d into a directory on the device.

1 Like

closed everything, except for firefox and vim, have nothing to do with usbstick, it is still “target is busy”
is there any thing that can be use to see what is holding it back ?

$ sudo fdisk -l
Disk /dev/sdd: 29,82 GiB, 32015679488 bytes, 62530624 sectors
Disk model: Cruzer Slice    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdd1  *     2048 62529535 62527488 29,8G  c W95 FAT32 (LBA)

$ sudo umount /dev/ssd1
umount: /dev/ssd1: no mount point specified.

Now it says “no mount point specified” - does that means it has being unmounted ?

It should be /dev/sdd1

You have a typo.

1 Like

Oh. :flushed:
Ok, it is still “target is busy.”

Is sudo umount /dev/sdd1 same as dolphin > right click (on the device) > safely remove (look like eject sign) ?

Tried to “safely remove” the usb stick in dolphin:


There is nothing that is accessing that usb stick.

it is done already.

used
$sudo umount -l /dev/sdd1

You have it open in dolphin and it is mounted as /run/media/enos-andrew/winboot7

Have you tried ejecting in plasma from the tray icon?

1 Like