Sudo issues

Every so often my password fails to make me root. It still logs me in. Once I change it from the settings the sudo works again. Is there some sort of timer on password validity for rooting?

Can you explain exactly where the failure occurs and what the exact error message is?


I didn’t save the logs but basically: if I type yay, when it asks for my password and i type the right one in, it says the password is wrong. Sorry, Try again And once I exit it says something like 2 attempts at sudo password failed

I logged out and when I tried to log back in I had to wait 10 minutes for it failing to authenticate 3 times.

I’m looking into the system logs right now to see if I find anything.

That sounds like it is working correctly. If you input the wrong password a few times - it will lock you out for a set amount of time. it’s a safety in case someone is trying to get into your computer nefariously.

Problem is, I’m pretty sure I put the correct password in. This isn’t the first time either. I have a password manager and I just copy paste it from there.

Still looking for relevant information in the journal logs. The problem is solved on my computer. Just by changing the password in settings. But I’m still concerned as to why this happens.


faillock [–dir /path/to/tally-directory] [–user username] [–reset]

sudo faillock --user *username* --reset

but if it fails for your users password randomly there will be something wrong could be a defective keyboard … or some sort of caps lock numlock setting on…

1 Like

Actually… it’s happening again. I’m not sure how to prove to you that it’s the right password or if there’s an error with the keyboard. The password copies fine to other windows.

Screenshot from 2023-02-26 19-32-00

you can check if it outputs correct letters and signs in editor or terminal… outside the pssword prompt…

1 Like

Err…that won’t work if they can’t use sudo…

I’m going to assume for now it’s a miss copy. I waited and got it to work again with the same password. Faillock fails to print out anything though.

Gosh i hope i didn’t make a dumb mistake like that xD

indeed ,)
faillock --user *username* --reset

1 Like

This is not exactly the best, in case there is a combination of fonts, locale, and other configuration in rare cases.
If you want to troubleshoot, set a simple password with numbers only and test behavior.
Another thing to test is with a brand-new user account.

1 Like

wonder if you could try a different terminal…
as you say it works in other “windows”

If sudo fails more times than it works, then re-installing pambase might help.

You would have to keep typing the below until the sudo command works:

sudo pacman -S pambase

As the other posts indicate, something seems to be messed up with pam?

If you know the keyboard works and you know you entered the password correct…

This issue generally appears quite often when there is a mix-up in between locales and keyboard-layouts…

For troubleshooting, I’d start checking the (different?) keyboard-layouts installed (xorg and system e.g.).


Could it be, that an additional blank-space is copied after the password, thus rendering the pwd wrong? Kate loves to do that, I just learned while familiarizing with a pwd-manager for the first time.

1 Like

Hey everyone, after some time, i’m relatively sure that it’s an encoding issue. copy pasting effects certain things.