Sudo authentication no longer worked after update

hello all!

I did pacman -Syu yesterday and this morning I couldn’t use the sudo command as it kept failing. Restarting fixed the issue though (using su to reboot).

I do remember seeing an update to the sudo package as well.

Is this normal?

Thanks

Well, it happens. It happened to me this morning when I updated (the update before I got the new sudo actually). I’ve seen that perhaps removing a lock file might be a solution, but it’s easy (and quick enough) to just reboot the pc (ssd).

Here sudo works as expected.

Can you show everything about the command and the output?

Happened to me last November.
Fixed it installing openssl-1.1

Ref: see Problems with libssl.so and libcrypto.so after 2022 Nov 5th updates - #5 by storm

Cheers

It is not uncommon that some just updated packages require a reboot. I guess we have to add sudo among them. :thinking:

@a86 you can get logs from the boot session with the issue, with

journalctl -b -1

Replace number one 1 with another number, depending on how many times you have rebooted since. man journalctl

https://paste.sh/vBgaCU5w#39RM4mRmua014OhXRAKjXQfD - 1
https://paste.sh/wjhcXXsg#0117vlWIP6F5B1bWKUC7vHxm - 2

If needed I can do a full system restore and try re-creating the steps as I’m using btrs with timeshift. I took one by one with logs… but I feel this is more of an Arch mainline issue rather than EOS?

Is it possible to have pacman not update certain packages like sudo, the linux kernel, bootloader etc? Is that something people typically do?

Partial updates are not supported since they may cause serious problems in the system.

No, but you can block/postpone (the whole) package update, if you have your reasons.

What you asked: No
What I proposed above: Yes

What exactly have you posted? Those logs look like one small part at boot start…
Paste errors?..