Suddenly invalid password

I was playing a Minecraft Modpack and it froze on me, and I force rebooted it.
After I booted into the system and when I entered the password into LightDM, it said invalid password. i tried multiple times, switching on and off CapsLock and NumLock and even shown the password and I was sure that the password is correct but it still said incorrect. I rebooted multiple times, with no success in logging in. I tried logging in with the TTY, no success. When I logged in as root through the TTY and the did su <my username> and then I did sudo ls and entered my password and… it worked. But I still couldn’t log into the DE. I have no idea what happened.

Reset the password:

sudo passwd <YOUR_USER_HERE>
## e.g.
sudo passwd xircon

if there were three incorrect login attempts, a faillock gets triggered. Read about it at

it can be cleared. Bit of a hassle, but a security bump for your computer and it’s data.

1 Like

I already tried that many times.

I tried faillock --user username --reset, still not working. It may be an issue with LightDM or with the TTY.

By the way, I also created a new user named test, and I still can’t log in. I also had timekpr-next installed for some reason, and I uninstalled it. Still can’t log in.

I also noticed that the directory /etc/ssl doesn’t exist.

Maybe this is silly, but:

For anyone that stumbles on to this thread the above command can be misread, and should be understood:

faillock --user your_user_name --reset


What happens if you login to the TTY as root again and:

pacman -S pambase

and then reboot?

1 Like

The password in your filesystem is probably corrupted due to the forced reboot without using REISUB.

Not a likely situation. The password file/database would have to be open with writes pending to get corrupted when a forced reboot occurs. The password file/database isn’t a commonly open file.

Ok, sorry if i didn’t respond for a while, I didn’t have access to my phone or computer.

When I do pacman -S pambase I get some errors that end with error setting certificate file: /etc/ssl/certs/ca-certificates.crt.
I checked if the mentioned file exists, and in fact, it does not exist. I am going to try some file copying shenanigans to get the certificate file, I will update you on when I do so, and about the outcomes.

I managed to reinstall coreutils, and now /etc/ssl/certs is not empty, but there seem to be no .crt files in that directory.

I reinstalled the package ca-certificates-utils with --overwrite="*" and some changes to the pacman.conf to override the certificate checking, now i think i fixed it. I am now going to disable the testing repos and perform a full system upgrade. Will update on the situation later.

I forgot to update y’all on the situation. I did the full system upgrade and got some errors while compiling python2, and fixed them. But the main problem has not been fixed. I have been playing Minecraft and browsing the internet in uncustomised vanilla xfce as the root account for like almost a week, and I want to go back to my natural habitat, which is my personally customised KDE installation, but I am kinda getting used to it.

i would say system is screwed a lot… python2 ? why? how does it happen you have to reinstall ca-certificates-utils ? removed some system directories manually maybe or done some uninstalls where it takes half of your system with it… testing enabled? why ??? (3 questionmarks) you could try reinstall all packages pacman -Qqn | pacman -S - and use eos-packagelist "KDE-Desktop" to force reinstall KDE Desktop packages.

But hey … in some case save your data and reinstall … if you have done some false inverse tinkering…

1 Like

Ok. I am now trying to force reinstall all of the packages on my system. I hope it will fix this main problem and many other problems with my system. Wish me luck!

1 Like

Also, now I will answer your questions: python2 is a dependency of a lot of packages, especially AUR packages. I enabled my testing repos at some point because I wanted to get the absolute latest version of all packages, and I’m also a risk taker with my system, which is not really a good thing. I don’t know what happened, everything worked well, then Minecraft crashed and I force rebooted, and suddenly I can’t login anymore. I am sure that there isn’t any Fractureiser stuff going on, and also Francureiser is a silent virus, and it couldn’t have done this. Maybe it could have been a different malware, or it could have been a freak accident.

Reinstalling all packages is going to take absolutely copious amounts of time, and it could have some errors or storage problems, but this is for my system’s own good.

great misconception about testing repository on archlinux. It is only for testing for issues on packging before they went into the official repositories. if you want ver latest versions better go for *-git versions from AUR.

Ok, I am not going to enable my testing repos for no reason anymore. I have learned my lesson

The progress is looking good, I have successfully reinstalled over 2500 packages out of about 3360.