Stuck on a black screen with a cursor after restart

Hi, I have the following issue: after my OS starts up and I submit the decryption password, a mouse cursor appears but it gets stuck on that black screen.

Only hard resetting the computer 2-5 times eventually makes it load up. This happens every time. It doesn’t matter if an update happened during that session or if I simply restart it, it’s always stuck on that black screen.
Bluetooth devices, my external monitor, all work.
I’ve tried restarting with turned-off gnome extensions, didn’t help.
Reinstalled all the packages with pacman, also nothing.
Running killall -3 gnome-shell to restart gnome crashes it completely.

Here’s the output for journalctl -p 3 -xb -1

Seems like something must be wrong with gnome, but I have no clue what.
I’ve got all the updates installed.
Kernel: 6.4.12-arch1-1
GNOME 44.4

Any help would be highly appreciated!

Seems like a bunch of stuff related to nouvea drivers in there. Not sure what the problem is though.

Is there a way to disable them completely (I don’t see a dedicated nouvea package)? I also don’t have nvidia package installed and I rely on the intel integrated graphics instead.

You can blacklist the Nouveau driver by adding a .conf to etc/modprobe.d/.

sudo nano etc/modprobe.d/nouveau_blacklist.conf
blacklist nouveau

I’m not so sure that will help with this issue though, because you have a lot of other errors and at least one failed service not related to Nouveau. It might be more of a general kernel issue.

What is your method for installing the updates? That kernel is not up to date.

Boot the live ISO so you can chroot (be sure to get the EFI partition mounted as well), then run


Log into the forum from the live environment and paste the output from the update into the thread so we can see what is happening if you’d like.

Here is the wiki post for setting up a chroot if it is helpful:

I’m using yay for that, but even running pacman -Syyuu doesn’t show any new linux update either.

I’ll let you know after I try with the live ISO.

Well, actually, it is…it’s been flagged as out-of-date, and 6.5 is in the Testing repo, but 6.4.12.arch1-1 is the current kernel:

You are right, my mistake–I must have been thinking of something else. Apologies for the confusion!

1 Like

I’ve tried blacklisting the Nouveau driver and looks like that did the trick. I restarted it 3 times and so far it booted up without issues every time. Thanks!