Stuck boot [Nvidia problem]]

Hello
Woke up with my computer getting stuck t this screen.

So I tried using startx but it crashed and the logg pretty much says “failed to initialize the Nvidia kernel module”.

Looked through some forums where they all say “use nvidia-installer-dkms” the problem is that I have is all installed but I get “command not found”

So now I feel styck and no idea what to do next.

@ExDebianuser installed nvidia-hook and it seemed to fix it, try:

sudo mkinitcpio -P

Then reboot.

I tried it

Didn’t work and got another error.
Looks like the system dropped the ball somewhere.

How recent is the install?

Think I have had endevouros for about 1-2 weeks.
Though replaced Nvidia with nvidia-dkms today to see if it would make any difference.

So this is dracut? I just converted, but:

sudo dracut-rebuild

Check if dracut:

pacman -Qs dracut
local/dracut 056-1
    An event driven initramfs infrastructure
local/eos-dracut 1.0-2
    Dracut scripts and hooks for EndeavourOS

It may differ as my install was converted :smiley:

Welcome to the forum! :smile:

Note that nvidia-installer-dkms is outdated and instead one should use nvidia-inst.
See nvidia-inst -h for info about the options.

First I suggest you run command

nvidia-inst -t

to see what changes it plans to do. If they are OK, then you can run the same without the -t option (and add other options you might need).

The command nvidia-inst worked after I installed it. Wasn’t installed by default.

Still have the same error.

Here is a part of my Xorg.0.log since I don’t have the possibility to copy the file to my phone.

Please show the URL returned by command

inxi -Gza | eos-sendlog

Https://0x0.st/oh0k.txt

I assume you need to add kernel parameter ibt=off.
This probably was mentioned in the output of nvidia-inst -t.

Or do you have it already?

My Nvidia-inst -t gives me.

Have no idea how use grub commands.

Can’t remove suggested package gets this prompt

Try option --32 for nvidia-inst -t.

You have AMD CPU?

That is correct I have an AMD CPU.

Then you don’t need ibt=off.

That is one less thing from the list.
Though running the suggested commands does not change the output from Nvidia-inst.

And tried Nvidia-inst --32

And no change.

The -t option does nothing but shows what it would do if allowed.
Now it only wants to add the kernel parameter nvidia-drm.modeset=1.

So you can just

  • run: sudo pacman -Syu and reboot if needed
  • take the -t option away from the nvidia-inst command and run it
  • run grub related commands (at least grub-mkconfig …)
  • reboot

and see if that helps.

Note: if any of the commands seem to fail, do not continue further but show the problem here.

Did a -Syu update for the system

When using Nvidia-inst I still get the steam Vulcan conflict as shown in pictures above.

Used Nvidia-inst --32 instead.

Updated grub mkconfig

And still the same problem.

Might try and remove Vulcan and steam when I get back home from work later to see if it’s something with that part.

Nope still nothing.
Could use nvidia-inst without any errors but did not change anything else.
Still get the same error log from xorg.

Even tried Nvidia-inst --conf --32
To see if it kicked any life into xorg but nothing.

I just copied /home and reinstalled it all.
So no true solution just a classic reinstall and rebuild.