Stuck at systemd-boot

Is there any way to access terminal from here? I’ve tried ctrl+ f1-f12, ctrl+alt f1-f12, alt + f1-f12

Optionally, i would be fine with accessing boot menu. But that doesnt seem to be possible
Thanks in advance.

Use your Live USB and run a command like sudo blkid or the like.

Look for the UUID shown in your screenshot.

Mount your system partition an look inside /etc/fstab and if using Grub, then inside /etc/default/grub and/or /boot/grub/grub.cfg. Compare with the UUID in your screenshot.

You could also post the above on the forum as well. Plus perhaps:

efiboomgr -v
sudo parted -l

Im not able to access any live USB media since i cant access bios/boot menu as mentioned earlier.

Only solution in my mind currently is to detatch my m2 SSD, but i’d like to avoid that.

Sorry I couldn’t read that in your first post. “boot menu” could refer to Grub’s or systemd’s boot menu as well.

Anyways, couldn’t you try any of the function keys (or other keys) relevant for your machine to get into your BIOS? Or doesn’t that work either?

Unfortunately not. Keyboard is totally unresponsive after installing endeavour os.

If i could get access to the terminal or bios i would be able to resolve this problem.

some device need (FN) key also pushed

it no help here :pray: for future ref have read this .

" [Tip] Enable Magic SysRq Key (REISUB) "

1 Like


On your Grub/Systemd boot menu, press e on the boot entry to edit the boot options.

Add: init=/bin/sh to to those options. For Grub, it would be in the line that begins with linux.
Go on booting by pressing Ctrl-X for Grub and I think only enter for systemd-boot is enough (not sure; try it for yourself)

This will drop you in a root shell from there you could take some recovery measures.

If that is still the case, I don’t know what else to suggest.

Thanks for all the suggestions.

I want to clarify that im able to reboot the computer by pressing ctrl + alt + del. That is why i was hopefull about finding a way to the terminal

Try what I suggested above. It will get you to a terminal. A root terminal.

Or you are not seeing any boot menu at alll?

Then while rebooting, press left shift key. This will hopefully bring up the boot menu.

Shift, ctrl+x, e does not work, since the keyboard is still unresponsive at this point.

That beats me!

Looks like your system has been hit by an unfortunate combination of rarities :expressionless:

Please wait to see if other forum member could chime in with other suggestions.

you’re doing something wrong if you cant access the bios… maybe try another keyboard in a different port.

I’ve tried all the ports.

There are others with similar issues

I resolved this by removing the ssd with broken endeavouros boot.

  1. Went to BIOS and changed boot options
  2. Plugged ssd back.
  3. Fixed the broken partition with live USB
  4. EndeavourOS boots normally
  5. Still cant access BIOS with keyboard, but that is a separate issue
1 Like

Would you mind sharing what the problem was and how you fixed it?
This could help other users with similar issue in the future.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.