Stuck at [OK] boot screen after update


I have been using endeavour for a while now and everything has been running smoothly. I normally just use yay to update or use the welcome menu. I’m in no way used to navigating the system but I get by as I only use my laptop for basics. This time I have no choice but to ask for help, I have seen and done everything any post that has an issue related to mine suggested but to no avail. I have reinstalled through a live iso so many times but the update never succeeds. I also forget to time shift so that’s my bad. Please help me if you can.

Hi @Yassir1, can you give some examples of what you have tried? Did any of your efforts change the boot process in a noticeable way?

What have you reinstalled so many times from the live ISO?

What bootloader is in use? The most common ones would be Grub or systemd-boot.

Do you know if you are using dracut or mkinitcpio?

What login manager are you expecting to see? What desktop environment do you run?

Have you tried reinstalling the kernel and headers, or rebuilding the initramfs from a chroot on the live ISO?

GNU GRUB is the bootloader in use. For what I have reinstalled, it’s the whole OS, just completely erased the disk and installed endeavour again. As for what I have tried, it’s been Chroot and tty among other things I can’t recall. I live in China so even updating the mirrorlist was a bit annoying as I have to do it manually. Moreover the keyring also needed updating but I managed all of that successfully, the problem is always post upgrade reboot. I keep getting stuck at the same screen but not always the same line. For the other questions I’m sorry I just don’t know. I’m only using endeavour because I have an old machine with just 30G so I’m quite a newb. Thanks for whatever help you can offer.

I use the xfce desktop environment because I need super lightweight. What I’m expecting to see is the login screen.

The drm is the Direct Rendering Manager. It says it finished but since that is the last message maybe it’s related to your gpu drivers? Can you access a tty; ctrl+alt+F2?

I cannot access tty

Maybe you need to start from the beginning and post the hardware info from a live ISO.

inxi -Faz

Try Ctrl + Alt + F3. Ctrl + Alt + F2 is used to exit tty and head back to Graphical User Interface iirc. At least that’s how it works on my system, and how it was when I looked it up when I had issues.

Do you have network connectivity issues?

What network card is in use?

Check out this solution from the Arch forum, involving disabling NetworkManager for the boot process and enabling it again after the system is up:

Kernel: 5.19.7-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: initrd=\arch\boot\intel-ucode.img
initrd=\arch\boot\x86_64\initramfs-linux.img archisobasedir=arch
archisolabel=EOS_202209 cow_spacesize=10G
nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 nvme_load=yes
Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
v: 4.16.1 vt: 1 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
Type: Detachable System: HP product: HP x2 Detachable 10-p0XX v: N/A
serial: Chassis: type: 32 serial:
Mobo: HP model: 827C v: 93.23 serial:
UEFI: American Megatrends v: F.35 date: 06/03/2020
ID-1: BATC charge: 0.1 Wh (1.6%) condition: 6.1/32.6 Wh (18.7%) volts: 7.2
min: 7.7 model: Intel SR 1 SR Real Battery type: Li-ion serial:
status: discharging
Info: model: Intel Atom x5-Z8350 bits: 64 type: MCP arch: Airmont level: v3
built: 2015-17 process: Intel 14nm family: 6 model-id: 0x4C (76)
stepping: 4 microcode: 0x411
Topology: cpus: 1x cores: 4 smt: cache: L1: 224 KiB
desc: d-4x24 KiB; i-4x32 KiB L2: 2 MiB desc: 2x1024 KiB
Speed (MHz): avg: 926 high: 1920 min/max: 480/1920 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 480 2: 1920 3: 480
4: 827 bogomips: 11524
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass status: Not affected
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:22b0 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD
type: USB driver: uvcvideo bus-ID: 1-4.2:6 chip-ID: 05c8:03a3
class-ID: 0e02 serial:
Display: server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
s-diag: 398mm (15.69")
Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x18d4 built: 2013
res: 1280x800 hz: 60 dpi: 148 gamma: 1.2 size: 220x140mm (8.66x5.51")
diag: 255mm (10") ratio: 16:10 modes: 1280x800
OpenGL: renderer: Mesa Intel HD Graphics (CHV) v: 4.6 Mesa 22.1.7
direct render: Yes
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
Imaging Unit vendor: Hewlett-Packard driver: N/A alternate: atomisp
bus-ID: 00:03.0 chip-ID: 8086:22b8 class-ID: 0480
Sound Server-1: ALSA v: k5.19.7-arch1-1 running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel modules: wl pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:3165
class-ID: 0280
IF: wlan0 state: up mac:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-4.1:5 chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Local Storage: total: 96.58 GiB used: 0 KiB (0.0%)
ID-1: /dev/mmcblk0 maj-min: 179:24 model: SDU1 size: 60 GiB block-size:
physical: 512 B logical: 512 B type: SSD serial: scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
ID-2: /dev/mmcblk2 maj-min: 179:0 vendor: Samsung model: BJNB4R
size: 29.12 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: rev: 0x8 scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
ID-3: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Edge
size: 7.45 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: rev: 1.20 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: N/A size: 10 GiB used: 79.7 MiB (0.8%) fs: overlay
source: ERR-102
Alert: No swap data was found.
System Temperatures: cpu: 46.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 200 Uptime: 12m wakeups: 25 Memory: 1.83 GiB used: 1.45 GiB
(78.9%) Init: systemd v: 251 default: multi-user tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 895 libs: 212 tools: yay
Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.21

That didn’t work for me

Please use code tags around what you post from the terminal output.