Stuck at mounting /boot/efi

Hi, ive just started using linux not too long ago, after having moved from kde neon.

After shutting down my pc and booting it again at a later date, I’ve been running into this issue where my boot will stall at mounting /boot/efi and sometimes loading kernel modules dm_mod and loop. I’ve tried changing kernels to both lts and zen which doesnt allow me to boot either.

I’ve tried to reinstall the entire OS with the grub bootloader which allows me to boot into the system until I shut it down.

Could this be related to the later kernels? Since I havent encountered such an issue when I was using ubuntu lts before swapping.

Attached are pictures of my issue

Here is my last boot attempt log - as well as system information -

Hopefully, it’ll help anyone more knowledgeable about this in helping me troubleshoot my issue. I’ve run into a wall as whatever I’ve tried to do, such as inputting ibt=off in the grub boot menu hasn’t worked so far.

Hi @Stalkingwolf, this might be a long shot but check out this post from the Arch forum:

1 Like

Thanks for the guidance! I’ve just reinstalled endeavouros, so I’ll try the linux-rt-lts kernel when this error happens again.

Okay, so I managed to find out what was the reason behind this issue. My bootloader wasn’t installed properly I think since I’ve been running with a Windows 10 dual boot and created another EFI partition on the same drive instead of using the one that Windows created. Which resulted in this weird issue after rebooting.

should not cause issues only needs to chose the right nvram entry from firmware.

Yea, I’m not so sure as to why its causing this issue since after I used Window’s EFI partition, it hasn’t occurred thus far while it would basically happen the moment I shut down my pc before.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.