Stuck at "Loading initial ramdisk"

Hi all, I’ve been using EnveavourOS for almost a year now but recently, maybe after some update, the system gets stuck at “Loading initial ramdisk…”.
After several days spent searching the web for fixes I finally gave up and I’m now posting here in the hope of not having to reinstall.

The issue doesn’t arise always, it will get stuck for a few boots, then work normally a few more, then get stuck again.
It happens both with linux and linux-lts, when it happens there is no journal entry and I can’t move to a TTY. The only way out is hard rebooting.
Removing the “quiet” kernel parameter and raising the loglevel to 4 also doesn’t show anything.

I’m on EOS Gnome on a laptop dual booting with Windows, with btrfs + snapshots and GRUB since it’s a one year old install.
In case it’s relevant I used a kernel parameter (that I now can’t remember) to completely disable my NVIDIA gpu and only use the integrated Intel gpu, plus on this laptop suspension and hibernation never worked on any linux distribution.
The system however always booted fine regardless of this issue and gpu being disabled so I don’t think it’s related.

Here’s my inxi -Fxxc0z: https://0x0.st/HXjL.txt

Thank you all in advance for your help

First of all i see it is on the current kernel so you must have been able to update it. Were there any issues during the updates? 6 months is way too long for updating a rolling release.

Also i don’t know the reason why you would disable the nvidia gpu entirely. It’s a hybrid laptop so it won’t use the nvidia anyway unless you use a method to switch graphics. This is not how i would do this. I would want the drivers installed for the hardware even if I’m not using it. Just my opinion. :man_shrugging:

Maybe you can post the url for the commands.

cat /proc/cmdline | eos-sendlog
sudo dmesg | eos-sendlog
journalctl -b -0 | eos-sendlog

Hi! Thank you for replying!

I meant that I haven’t booted Windows in 6 months, I update EOS regularly. Sorry if it wasn’t clear, I’m going to edit the post now to clarify.

I think I disabled it because someone suggested it might interfere with suspension but as you said the nvidia gpu wasn’t running anyway so it didn’t make any difference.

I’ll post the urls that you requested, but keep in mind that since when the boot fails the corresponding journal isn’t created, the journalctl -b -0 will refer to a successful boot.
I am by no means a linux expert so maybe you can see something useful in those logs that I can’t.

https://0x0.st/HXeO.txt

cat /proc/cmdline | eos-sendlog

https://0x0.st/HXeV.txt

sudo dmesg | eos-sendlog

https://0x0.st/HXey.txt

journalctl -b -0 | eos-sendlog

Also I should mention that this issue started manifesting about a month ago, maybe more, but I didn’t have the time to investigate it until now.

I am not a linux expert either. I don’t see any kernel parameter in the command line that would stop the nvidia gpu. I didn’t see the hardware listed also. I only see the Intel Gpu. I guess you don’t have any drivers loaded for Nvidia. Also I’m not sure if you are using grub or sytemd-boot?

Maybe post

inxi -Ga

I do see many errors related to pcieport but don’t think that is an issue. There are a lot of other error messaging related to the Gnome desktop but again i can’t pin anything down to causing it to not boot.

Yeah I think I blacklisted the gpu driver.
I’m on grub.

I also see all those errors but I think they were there before the issue started happening.

Here’s inxi -Ga
https://0x0.st/HX_1.bin

The url isn’t any good. You can just post the output of inxi -Ga as it isn’t very long.

Edit: I’m not sure where you blacklisted the nvidia gpu as i don’t see any kernel parameter in the command line.

I would have suggested a rebuild of the initrd:s but since:

I am not sure … :thinking:

How much you wait before you reset the pc? I had something similar, sata cable wasn’t connected properly.

Also try higher loglevels 5 or 6. I think you have to remove quiet too, not sure. Maybe you will notice something.

Here’s inxi -Ga:

Graphics:
  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
    empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:191b
    class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-4:2 chip-ID: 13d3:5666 class-ID: 0e02 serial: NULL
  Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.1.1
    compositor: gnome-shell v: 43.4 driver: X: loaded: intel
    unloaded: modesetting alternate: fbdev,vesa dri: i965 gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x15d2 built: 2015 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 530 (SKL
    GT2) direct-render: Yes

As for the driver, I found the configuration in /etc/modprobe.d/blacklist-nouveau.conf:

blacklist nouveau
options nouveau modeset=0

Yeah I already tried to rebuild them with sudo mkinitcpio -P but it didn’t work unfortunately

1 Like

I usually wait 2 or 3 minutes, maybe I’ll try for longer. In my case though it’s laptop so cables shouldn’t be a problem.

Thank you for the suggestion, I’ll try higher log levels.

Okay i see how you are doing this then and since you don’t have nvidia drivers installed so no hardware shows. :+1:

I have been looking at every post on “Stuck on Loading Initial ramdisk” and so far have not seen ANY solutions. My Endeavor install does this EVERY TIME I do an update. I have done all of the usual things: chrooted and reinstalled grub, mkinitcpio -P, formated efi partition. Still does not boot. Then all of a sudden some combination of factors allows it to boot and then I don’t have a problem until the next reboot.

Is this an Endeavor Bug? Arch bug? something wrong with the install? At this point, it’s making me think about abandoning this distro all together and going back to Ubuntu to be honest.

UPD: Re-installed the OS completely making sure to format the /efi and / partitions. Also changed to using the default Boot manager (not Grub). The FRESHLY installed OS is not booting. The hardware I am installing on has not had any issues with Ubuntu or Manjaro by the way.

Hi @peterg75, welcome to the community.

You should start a new thread for your issue, where you can provide some information about your specific configuration and describe your troubleshooting efforts so far so people can try to help you. A new thread will have better visibility in the forum than this old thread from April.

“Stuck at loading initial ramdisk” is a common error; this thread you have added your comment to is unlikely to be related to your issue.

I think I have gotten past the issue with the new install. I had multiple boot options in BIOS so I unchecked the one from the old install and it worked for now. I’ll see what the behavior going to be after the next update and if I get into the same issue, I’ll open a new thread. Thank you.

Sorry for the frustrated posts before. I’m posting this here in hopes that if someone finds it by searching they will not be as frustrated as I was.

It turned out that all of my issues were related to an out-of-date BIOS (Firmware) of my laptop. Once I updated the BIOS to the latest version from Dell, all my issues with the stuck boot were resolved. For reference, the laptop is Latitude 7400 with Core i5 8th Gen.

1 Like

This is why i always recommend updating the Bios as a first step if it’s outdated.