Struggling to get cpupower command to run on startup

Hello. Currently, the method I’m using to run startup commands is a systemd service in /etc/systemd/system. Somewhere there was a fantastic forum post about how to implement this and why it’s the recommended way to do a startup script, but I can’t find it.

I use this script exclusively to run power-control commands: powertop --auto-tune, make an exception for my wireless mouse, put the frickin’ boot on baloo-file’s neck, and use cpupower to set a more economical power profile. All but the latter work. I’ve been living with this for a while, and now I want to fix it.

I can only guess that this has something to do with the startup script running too early, so something overwrites the cpupower command, or perhaps there’s some prerequisite that hasn’t started yet. I’d appreciate any suggestions.

What would be even better, though, is if there were a way to command a cpupower performance change on startup, AND whenever the laptop is un/plugged. If anyone can think of an easy way to do that, that would be awesome.

Just follow the wiki, it works for me. Edit the config file and don’t forget to enable the cpupower.service.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.