Streaming from Vu+ Uno and OpenWebif - VLC

Good morning, beings in my timezone!
I have a problem with streaming video from a Vu+ Uno 4k via the OpenWebIf and Browser. When clicking a link to stream it opens the dialogue to choose the application. For normal TV streams it is working with mpv and celluloid, but not with VLC. For recordings streaming is not working at all. I can download the recording and then playback, but that is not that convenient.
The thing is - using a KDE neon image to boot from everything is working as expected (clicking on streaming link opens VLC and streaming starts nearly immediately. Therefore it must be a misconfiguration on my desktop and not on the server or network.

Any suggestions where to look and what to look for?

Without knowing anything about the system you’re referring to, I’d start by looking at the differences between the working and non-working systems.

I have a VU+ Duo2 and streaming works fine for me with VTI image as well as with OpenATV image. I stream everything to mpv, including recordings.

The live program is streamed as *.m3u8 files, recordings are streamed as *.m3u files. May be you have an issue with the mime types.

1 Like

I think it may be related to my browser or some system setting since i get the same result when opening .odc documents from my nextcloud in my browser - on my endeavour standard it will download, but when booting from the kde neon stick the file opens in browser as expected (CODE server with nextcloud installed).

What you could try is to download the file and then open the downloaded file with firefox. Firefox will then, hopefully, ask you what to do with it resp. with which app to open it. Once you have select VLC for this task firefox will remember this and no longer download the streaming files but open them directly with vlc.

Yes this works, but is not what i expect from my system. Especially since it works when booting from USB. Therefore the services on my servers are doing fine but my system is misconfigured in some way :confused:
Furthermore i solved my initial problem - the stream was passwordprotected and the browser was not showing the dialogue. But the problem lies deeper, since my VLC is not working at all with the streams.

So either it is just coincidence or the installation of aribb24 solved the problem. Apparently this package is responsible for decoding .ts streams which are provided by my tuner. In the standard installation of VLC/arch it is missing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.