Strange printer PING issue

I’ve got a 2011 MacBookPro laptop and a 2019 iMac desktop - both of which are (happily) running EOS with i3wm. We’ve also got a brand new Pantum-brand wireless multi-function printer in the house… and here’s my conundrum:

The desktop can reach the printer. The laptop cannot.

I can’t figure out why except for this key distinction: The desktop can successfully PING the printer ( while the laptop cannot.

Instead, the laptop gets the dreaded “Destination Host Unreachable” error upon ping’ing the same printer IP address.

I appreciate there LOADS of reasons a printer connection can fail. So please allow me to eliminate many of them…

  • Both have systemctl cups.service enabled and running successfully.
  • Both have the same firewalld settings (i.e., “Home”).
  • Both have perfectly functional wireless internet access.
  • Both can successfully reach all other available IP addresses in the house.
  • Both have the same model-specific Pantum drivers installed.
  • Both show identical results via the route -n command.
  • Both run 6.0.10-zen2-1-zen kernel, i3wm, same environment, etc.
  • CUPS is happy to create connections to this printer, and I’ve set it up with both as socket:// connections. CUPS doesn’t complain.
  • The printer reports that its connection to our home wi-fi router is up and running (as proven by the iMac, which prints to it wirelessly).

And so, I’m at a loss to understand why the laptop fails to reach the printer through PING, yet the desktop is successful. Clearly, I’m overlooking something.

Any other possibilities to explain this difference in “reachability” that I might have missed? :thinking:

Without much thought:

  • Disable firewall even though you are “sure” both are set up alike.
  • Laptop, desktop and printer all on the same 192.168.1.nnn network.
  • Nothing strange in the /etc/hosts file.
  • IPv4 vs IPv6.
  • Can other devices see the printer? Cellphone, tablet?
1 Like

Thanks! All good ideas for me to pursue…

  • I thought setting both firewalls to the same “Home” setting would suffice, but I will go further just in case. Find a way to simply disable them for sure.
  • Yes, all devices are on the same network (i.e., the base wifi, not the 5G sibling). And by “all” I mean both PCs and the printer itself.
  • Never thought to look into etc/hosts … so I just compared, and the only difference between the two is the labeled “name” of each host address, otherwise identical in every respect.
  • Not sure about the 4 vs 6 distinction since I didn’t set either. How might I pursue this further?
  • Yes, there’s also my wife’s iMac which sits next to the printer and is connected via a USB cable. Works fine.
  • In addition, I’ve used an Android app on my Samsung tablet and successfully printed out to this printer. Didn’t even know it could do that :wink:
  • When I boot up both into Apple’s OSX on both the desktop and laptop (i.e., the one that’s misbehaving in Linux), they are both capable of printing.
    … Which suggests to me that the laptop’s inability to reach the printer wireless-ly (as seen by the PING failure) remains a Linux configuration issue unique to that installation.

The challenge for me is that I cannot find any difference between the two setups within their respective Linux environments to cause one to successfully ping, while the other cannot. :face_with_diagonal_mouth:

Also take a look at:
and see if any useful ideas pop out from that wiki article.

I install and use system-config-printer program to install and setup my printers.

@CMarch Thank you for the suggestions. I will pursue - and report back for future travelers if I discover anything helpful to address this odd behavior. :ok_hand:

An update:

Well, I finally got all of the Endeavour/i3 machines in the house to communicate and function with the printer (3 of them - a vintage 2019 iMac, more vintage 2011 MacBookPro and Dell Optiplex tower). I wish I could tell you exactly what I did, but it’s unclear.

I did give up on wifi since none of the computers could find (nor ping) the wireless IP address of the printer (except my Android tablet and iMac when booted in OSX). So instead I wound up connecting it via Ethernet hardwire (actually, powerline ethernet adapters through wall power sockets).

Then magically, not only could all of the computers communicate with the laser printer via ethernet ( but they could also suddenly communicate via the wi-fi ( IP address too. Huh?

Perhaps you have to establish an ethernet connection FIRST, then the wifi works?! There are other cases where I’ve seen this installation requirement … but nowhere in the printer’s manual nor in the CUPS support did I notice such a requirement (or troubleshooting suggestion)

So, if it’s any help to others in the future, I would suggest TRYING a hardwire ethernet connection first if having wifi printer connection issues. It might break the communications logjam. :vulcan_salute:

(PS - and to clarify, all computers now successfully ping the printer at both IP addresses noted above, i.e., both the wi-fi and ethernet connection respond).