Strange performance/error problem w/ images (from


I’m absolutely sure that this is the wrong sub forum, but for the life of me I could not find a better one. Please move as needed, thank you.

For a few months now I have a problem with loading images from a certain source. A few months ago it intermittently worked, but now it constantly does not. When I browse Reddit, I use the old style layout (, but I’m not sure if this is relevant.

When loading images from any sub board, these are almost exclusively hosted on I regularly get either an error that the is not available (I have not idea what that means), or get extremely slow download speeds.

I can see with my Windows machine (my business laptop) that this is not a question of my network. I am using Firefox with lots of privacy addons installed, but that doesn’t seem to be the cause. I’ve just now tried to fetch an image I could not get to load in the browser to (down)load with wget, and I see this:

[dromundkaas@Pure test]$ wget
--2022-09-27 21:32:17--
CA-Zertifikat »/etc/ssl/certs/ca-certificates.crt« wurde geladen
Auflösen des Hostnamens (…
Verbindungsaufbau zu (||:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 7117478 (6,8M) [image/png]
Wird in »04kbigy6ndq91.png« gespeichert.

04kbigy6ndq91.png                                      1%[>                                                                                                                     ] 107,51K  --.-KB/s    in 92s     

2022-09-27 21:34:11 (1,17 KB/s) - Verbindung bei Byte 110090 geschlossen. Erneuter Versuch.

--2022-09-27 21:34:12--  (Versuch: 2)
Verbindungsaufbau zu (||:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 206 Partial Content
Länge: 7117478 (6,8M), 7007388 (6,7M) sind noch übrig [image/png]
Wird in »04kbigy6ndq91.png« gespeichert.

wget does several tries, but the speed is so low (<1kb/s) that it aborts or the remote connection is closed.

I would like to either confirm or rule out that Linux users are throttled by that site, so could somebody maybe test the image URL I tested to see if the problem is reproducible on other machines as well, I would be grateful.

It is certainly not an issue of your OS. Using dnscrypt-proxy here.

I guess there must be a reason, why the subdomain is named as

But then again, this one works well:

From this post:örde_wurde_der_warmwasserboiler/

Yes, that site seems to be experiencing some problems.