Strange issues with Wifi and Audio after update

Looks like the next batch of my daily EndeavourOS issues have arrived again.

A system update sometime ago messed up with my audio and wifi.

Previously, as soon as I booted my computer, the audio server (Pipewire) loaded alongside with it playing the Cinnamon startup sound, and the wifi would connect shortly after. But now, it takes nearly 30 seconds for the audio server to actually start, leaving me without sound this entire time. Not only that, but the computer displays me as having no wifi connection for an entire minute, and then spends a further 30 seconds attempting to connect to my internet, at which point it always demands I insert a wifi password despite it being supposed to remember it by this point.

Just what gives? Between this and my font issues, I’m considering just switching out to another distro again tbh.

Maybe a journalctl -b (bootlog) gives some insight, what is going on.
You could also provide important logs to the community (see Welcome app).
Also having a look at package management history using pahis could help. It helps to find out, which packages have been updated.

There was a bunch of updates for pipewire and some config files for alsa? I too had sound issues but after rebooting it straightened itself out. Seems to be working fine now. I was just getting tick tick tick tick tick as audio played. It’s fine now and i never had an boot issues. These were the updates i got last.

[2022-01-27T14:56:50-0500] [ALPM] upgraded alsa-card-profiles (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded pipewire (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded pipewire-jack (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded firefox (96.0.2-1 -> 96.0.3-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded gst-plugin-pipewire (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded pipewire-alsa (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded pipewire-pulse (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-27T14:56:50-0500] [ALPM] upgraded rubberband (2.0.1-1 -> 2.0.2-1)

You should! It’s the glory of Linux, there’s dozens, if not hundreds of distros out there. There’s gotta be one that scratches your itch. And if not, we’ll be here when you come back!

1 Like

I checked the (really large) systemd bootlog, but I can’t really make heads or tails about it. I’m sorry I’m stupid, but is anyone able to take a peek and realize what’s wrong?

I’ve been having this issue for over a week. hoping it’d fix itself eventually, but it never did even after several system updates. I’m losing hope at this point.

Yeah, I’m very heavily considering going back to Fedora due to its stability compared to Arch, but Fedora has issues of its own that Endeavour/Arch don’t have that puts me off from going back to it. Main issue is, Fedora is the only other distro that comes close to what I want for my system… so it’s not like I have a choice that I want. :confused:

Don’t lose hope and never feel stupid just because you don’t understand something. I think you have come a long way since you started on EOS. You just have to dig in and get your game on! Don’t give up! If it means trying something else for a while and then coming back? So be it! Might be you just need a break from the frustration. :wink:

1 Like

We all have choices. I’m assuming you’re on the LTS kernel since you’re not new, but if you aren’t- It’s substantially less temperamental with breakage than the latest. It should yield you a much better experience. I almost never have hardware issues since dumping latest. It’s much better imo.

I’m actually dual-booting the regular kernel with the zen kernel and was considering compiling the tkg kernel, I never really had more luck with the LTS kernel than the standard one ^^’

That’s a very rare case indeed then. In that scenario, you may in fact be better served by a non Arch distro as there’s a much higher chance of breakage on the latest and kernels based on latest than you usually see on the lts.

Can i see your hardware again?

inxi -Faz | eos-sendlog

Just F.Y.I.

Looks like there are a couple more UEFI Bios updates for that board. Most current is version 3211 2021/08/26

I see you are using the kernel parameter amdgpu.ppfeaturemask=0xffffffff for overclocking voltage features?

I’m assuming you are using the rtl8821au-dkms-git package for your WiFi which is a USB Dongle?

I don’t see any issues. This is on the zen kernel. Have you tried the standard current kernel also? The audio i can only say it’s working fine for me. You could revert to pulse audio or just wait and see if an update fixes it. Pipewire is kind of a work in progress. It keeps getting updates and changes.

Can you give us a couple more logs.

sudo dmesg | eos-sendlog
journalctl -b -0 | eos-sendlog

Yes and yes.

Looks like I’ll have to update my motherboard Bios yet again…

Exact same issue happened on the standard kernel last time I tested it. In fact, for a while, the issue only happened on the standard kernel while the zen kernel did not have this issue, but then the issue flared up on zen as well.

sudo dmesg | eos-sendlog

journalctl -b -0 | eos-sendlog

Well I’m just letting you know. Don’t worry too much about it. Eventually you’ll want to update it.

Nothing jumps out at me. I’m not an expert. There are lots of different informational messages related to some of the packages you have installed related to gaming such as wine. See how it goes and then decide what you want to do from here. Your choice obviously.

No suggestions for your audio, but for your wifi a couple that might help. I am assuming you are using Network Manager. In your connection’s properties in Network Manager change the settings to allow all users to connect at startup, and also to save your network password unencrypted. That may help with your wifi delay issues.

1 Like

There’s a new kernel just now. Maybe that fixes your issues with audio etc.