Strange Grub Issue

Odd issue here. I had my 3rd stroke a week or so ago. Neither my 1st two (10 years and 5 years ago) caused much tech tech knowledge loss. They were mostly physical. This time, I am occasionally struggling with simple stuff tich-wise. I run BTRFS and keep a GRUB backup on my main drive. Occasionally, the backup would get so large (I figured it was that since nothing else was growingwing that the drive space got lot really low. Using a graphic method, I would remove the grub backup and then recreate it using a command line grub-mkconfig command. Any help before getting my main drive screwed up would be greatly appreciated. I a honestly having a hard time remembering method other than remembering a kong-ass command to start the creation of a new .cfg.

To help remembering the grub.cfg creation command, you might want to create an alias into your ~/.bashrc:

  alias update-grub="sudo grub-mkconfig -o /boot/grub/grub.cfg"

Then start a new terminal (this also reads the new alias) and give command


Is this what you were after?

1 Like

What exactly do you mean by this? Explain, please, including details on the method, commands you use (script etc).


I took some time to re-explan things and do some of my own investigation into how I both did the first and second parts of things. First, the verbiage. I am looking to delete the oldest (or whatever I choose) btrfs snapshots I choose. I remember doing that in a graphic environment. I removed all backups and thgen recreated all of the backups and created one current backup using a grub-mkconfig command. Hope this helps more than my original BS. Deleting some snapshotsv would at leat stop me from getting low disk space errors.

In the past, you seem to have used Timeshift.
It has a graphical user interface, and commandline also.
It allows you to delete old snapshots if they are made with it.

I think I will just delete a week earlier than I had been before. I only rver got close before. so that should be enough goign forward.

I suppose the issue is more like a misunderstanding.
BTRFS/Timeshift snapshots are not actually backups, in the usual meaning. They can be referred to as Restore points for system rescue in case your system breaks.

When you have a fine working system, you can just delete all snapshots and create a new one and that’s it.

If you want data backup, you should use other utilities/methods.

If you still have an issue (I think this is mostly solved, no actual issue seems to exist IIUC), do give more info.


The BTRFS file system needs plenty of free unallocated space to work without errors.
When the disk starts to get full, the problems start at the latest

The oldest snapshots seem to take up the most free space.

1 Like

I think Petsam explained what I worded poorly in the first place. It is a restore point I was explaining. Let’s talk about how trying to remember how you setup your Budgie desktop (different computer) sucks even worse, LOL. You can’t really “edit” anything, LOL. Everything is new,

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.