Strange GRUB behaviour

Hello there,
I will try my luck here in Forum, maybe someone can help me, here’s my issue:

GRUB is booting in blind mode after a clean install, GRUB file looks good, and it should work, but it doesn’t, if I ad the following line GRUB_TERMINAL=console I do get to see Grub but only in console mode.
In Grub, if I type c and videoinfo no adapters or resolution are shown.
The same happens to other Arch based distros like ArcoLinux.
I always run Gparted 1st and install after.
I thought it could be something related to HW issues and installed a Debian based distro, the GRUB works just like it should.
In Debian GRUB I get adapter info: EFI GOP Driver and possible resolutions.

Im OK using the console mode for now but would like to have it like it should, maybe someone of guys can help me to sort it out.


1 Like

Welcome @DocLeo
There is an issue with grub. It’s pinned in the forum. If it’s a fresh install you probably only need to run

sudo grub-mkconfig -o /boot/grub/grub.cfg 

Not anymore :frowning:

Here’s the link:

1 Like

Okay so it’s not pinned anymore. I didn’t notice. :wink:

Could you just pin it back, for some 1-2 days?

@ricklinux @DocLeo
I don’t have the answer, but your issue is not related to that one in the referred post. It is a fresh install, so it doesn’t have the old Grub-install issue.

1 Like

Maybe start with providing a link to your hardware.

inxi -Faz | eos-sendlog

Thank you, I am on Grub 2:2.06.r322.gd9b4638c5-4, came with fresh install.
Didnt made any changes to Grub except adding this line GRUB_TERMINAL=console and
sudo grub-mkconfig -o /boot/grub/grub.cfg, this way i’m able to see grub when booting.

What happens if you comment that line out?

GRUB is hide, after 5 sec. boots to desktop

1 Like

Not good?

1 Like

No! i need the grub, having 2nd SSD with Windows on this setup.

1 Like

Yeah, I’ll pin it back if someone already hasn’t done so.

Why don’t you try reinstalling grub and then update it. Just to see.

There must be a reason why it was decided to unpin it as @Bryanpwo said this may not be a grub issue?


# Uncomment to enable Hidden Menu, and optionally hide the timeout count

Update grub afterwards and reboot.

It was unpinned automatically. I set it to this morning (the last time I pinned it). We’re still having stragglers both here and in telegram.


No, I said that this particular issue isn’t related to the known Grub issue, since it is a fresh install.
The post unpinned itself, there was a time limit to be pinned on that particular post. :wink: