Strange glitches

Hello, I just switched to linux, was on windows before. I have some strange glitches on my computer since I switched, they happen mostly when I watch videos and when I go on steam.
here is the link to a video of these glitches: https://youtu.be/41-XL00av5I
I am using KDE plasma, and I am a beginner.
I tried doing this:
sudo pacman -Syu
sudo pacman -S xf86-video-amdgpu
sudo pacman -S nvidia
sudo reboot

Then this:
sudo pacman -Syu mesa

And it got better, but I still have them even though I have less, and I think that my RAM usage also dropped. If you need to know my laptop’s components or anything just ask me.

Can you post hardware info with

inxi -FAZ --no-host | eos-sendlog

Can you also change the privacy setting of that YouTube video, currently it’s set to private and cannot be viewed.

System:
Host: Bongstong Kernel: 6.9.3-arch1-1 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.5 Distro: EndeavourOS
Machine:
Type: Laptop System: LENOVO product: 21FECTO1WW v: ThinkPad P16v Gen 1
serial:
Mobo: LENOVO model: 21FECTO1WW v: SDK0T76461 WIN
serial: UEFI: LENOVO v: N3VET26W (1.08 )
date: 08/07/2023
Battery:
ID-1: BAT0 charge: 65.5 Wh (74.9%) condition: 87.4/90.1 Wh (97.0%)
CPU:
Info: 8-core model: AMD Ryzen 7 PRO 7840HS w/ Radeon 780M Graphics bits: 64
type: MT MCP cache: L2: 8 MiB
Speed (MHz): avg: 858 min/max: 400/5137 cores: 1: 1540 2: 400 3: 400
4: 400 5: 400 6: 400 7: 1269 8: 400 9: 1397 10: 400 11: 2832 12: 400
13: 1298 14: 400 15: 1397 16: 400
Graphics:
Device-1: NVIDIA GA107GLM [RTX A500 Laptop GPU] driver: nvidia v: 550.78
Device-2: AMD Phoenix1 driver: amdgpu v: kernel
Device-3: Luxvisions Innotech Integrated Camera driver: uvcvideo type: USB
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting dri: radeonsi gpu: nvidia,amdgpu resolution:
1: 1920x1080 2: 1707x1067
API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast
platforms: wayland,x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.1.1-arch1.1
renderer: AMD Radeon 780M (radeonsi gfx1103_r1 LLVM 17.0.6 DRM 3.57
6.9.3-arch1-1)
API: Vulkan v: 1.3.279 drivers: nvidia,amd surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_ps
Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
API: ALSA v: k6.9.3-arch1-1 status: kernel-api
Server-1: PipeWire v: 1.0.7 status: active
Network:
Device-1: Qualcomm QCNFA765 Wireless Network Adapter driver: ath11k_pci
IF: wlan0 state: up mac: 04:7b:cb:c7:2a:ca
Bluetooth:
Device-1: USI driver: btusb type: USB
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: disabled
rfk-block: hardware: no software: no address: N/A
Drives:
Local Storage: total: 476.94 GiB used: 100.32 GiB (21.0%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL4512HBLU-00BLL
size: 476.94 GiB
Partition:
ID-1: / size: 467.39 GiB used: 100.32 GiB (21.5%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 1022 MiB used: 296 KiB (0.0%) fs: vfat
dev: /dev/nvme0n1p1
Swap:
ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
System Temperatures: cpu: 38.0 C mobo: N/A gpu: amdgpu temp: 36.0 C
Fan Speeds (rpm): fan-1: 2373 fan-2: 2090
Info:
Memory: total: 32 GiB note: est. available: 30.06 GiB used: 8.53 GiB (28.4%)
Processes: 358 Uptime: 38m Shell: Bash inxi: 3.3.34

Ok, I set it to public.

Thanks. Video still shows that it’s private. Setting it unlisted is also fine.

At a glance, it seems you have a hybrid setup with integrated GPU and discrete GPU (RTX A500). It looks like it’s currently rendering on a Radeon instead of the Nvidia one.

I don’t currently have HW to test hybrid configuration, and I’m not familiar with professional series Nvidia cards (A500), but as a GA107 card it should be supported by Nvidia drivers.

Check running nvidia-inst from following reply:

1 Like

That’s strange that you can’t see it, it is set as public. Here is a link that you should be able to see.

Screenshot:

Can someone else check is the video viewable for them?

1 Like

this one is 100% public, if someone has issues to watch it: https://youtu.be/d9YBgArjSrg

I did some strange premiere thing, unitentionaly

Try looking for a Hybrid Graphics switch in your BIOS.

Now it works :smile:

That really looks like GPU artifacts. I’ve seen reports of them on Nvidia+Wayland which you seem to be running, although Wayland support should have improved a lot within last year or so. This is assuming hardware itself is healthy as artifacts may also be caused by bad gpu/vram.

Try starting KDE in Xorg instead of Wayland and see if the artifacts are still there. You can choose it from Desktop session: setting menu on user login screen.

And as @ddnn pointed, check for Hybrid graphics switch in BIOS. Also check that your nvidia drivers are installed (nvidia-inst previously linked). AMD drivers are included in kernel and do not need installation like Nvidia does.

1 Like

Thanks, I don’t have them anymore. I stopped using the KDE wayland and chose the other and installed the nvidia drivers.