Strange bar behavoir in start menu and applets


Here are some images demonstrating the strange bar behavior. This is on a 7th gen thinkpad and KDE plasma.

:grey_question: :question: :grey_question: :question: :grey_question:
After update/upgrade?
Fresh installed?
It work before on other Linux/Win?
Please post
inxi -Fxxxza --no-host
No pics :smiley: :slight_smile:

Try going into system settings then desktop behavior and adjust the blur setting intensity.

1 Like

It’s a new install. The system is up to date. changing the blur doesn’t fix the issue.

Maybe wrong GPU driver/settings but without info no help :wink:

@Kaz
What is the output here:

loginctl show-session 1 -p Type

Failed to get session path: No session ‘1’ known

Do you get any output for inxi?

Edit: How about: echo $XDG_SESSION_TYPE

System:    Kernel: 5.4.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=3bee4aea-6fb9-4ab8-92e6-0e3d0fe51394 rw quiet 
           resume=UUID=55c63e1e-4d11-414e-a6d1-5f92a615274c loglevel=3 
           Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM Distro: EndeavourOS 
Machine:   Type: Laptop System: LENOVO product: 20R1000RUS v: ThinkPad X1 Carbon 7th serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20R1000RUS v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N2QET17W (1.11 ) date: 11/27/2019 
Battery:   ID-1: BAT0 charge: 43.8 Wh condition: 51.0/51.0 Wh (100%) volts: 16.3/15.4 model: LGC 02DL004 type: Li-poly 
           serial: <filter> status: Discharging cycles: 11 
CPU:       Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: C (12) microcode: CA L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 800 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 797 4: 796 5: 800 6: 800 7: 800 8: 787 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           Display: x11 server: X.Org 1.20.6 driver: intel unloaded: fbdev,modesetting,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.4.10-arch1-1 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 2000 bus ID: 00:14.3 chip ID: 8086:02f0 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Intel Ethernet I219-V vendor: Lenovo driver: N/A port: efa0 bus ID: 00:1f.6 chip ID: 8086:0d4f 
Drives:    Local Storage: total: 238.47 GiB used: 51.69 GiB (21.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HBHQ-000L7 size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 4M2QEXH7 scheme: GPT 
Partition: ID-1: / raw size: 221.33 GiB size: 216.86 GiB (97.98%) used: 51.63 GiB (23.8%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 16.84 GiB used: 57.2 MiB (0.3%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 302 Uptime: 19h 56m Memory: 15.31 GiB used: 3.79 GiB (24.8%) Init: systemd v: 244 Compilers: gcc: 9.2.0 
           clang: 9.0.1 Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.37 
1 Like

Its x11.
My neofetch is


        #####           kaz@euler 
       #######          --------- 
       ##O#O##          OS: EndeavourOS Linux x86_64 
       #######          Host: 20R1000RUS ThinkPad X1 Carbon 7th 
     ###########        Kernel: 5.4.10-arch1-1 
    #############       Uptime: 19 hours, 59 mins 
   ###############      Packages: 1023 (pacman) 
   ################     Shell: bash 5.0.11 
  #################     Resolution: 1920x1080 
#####################   DE: Plasma 
#####################   WM: KWin 
  #################     Theme: Breeze [GTK2/3] 
                        Icons: breeze [GTK2/3] 
                        Terminal: konsole 
                        CPU: Intel i7-10510U (8) @ 4.900GHz 
                        GPU: Intel UHD Graphics 
                        Memory: 3976MiB / 15678MiB 

                                                
                                                



Is xf86-video-intel driver installed?

No it wasn’t, so I installed it, which caused this madness. <https://drive.google.com/file/d/1wIINqbdXK460FWYXUGB1WDLUo6cujeCd/view?usp=sharing> My tty’s still work, but everything else is broken.

I just asked if it was installed? You didn’t answer back. Did you uninstall it from the TTY?

Yes. The computer is now back to normal.

When you say normal? You still have the issue with the strange bar behavior?

Yes, that hasn’t been fixed. I tried installing latte dock to see if the problem is unique to the to the default dock. This didn’t fix it.

So this is afresh install of Plasma. Have you made any changes to the settings? Installed a bunch of programs? Was it like this right from the start after installing?

1 Like

The problem was present when there were no programs or updates installed; when it was completely fresh. Since then, I have installed programs, and customized KDE, but the problem has persisted.

Have you tried going into settings, display & monitor and turn off composting?

(Enable compositor on startup) -turn off to test

You can try that and see. Not sure of you have to restart or just log out and in. If it doesn’t change anything just put setting back.

Hm, I restarted my compositor with a different version of opengl, and the problem went away.

1 Like