Strange auto-switching workspaces with app drawer use, super key, or just on it's own


I’m sorry but I don’t know how to explain this or I would have searched for it. The super key is automatically adding workspaces, the app drawer button does the same. Once in the app drawer, it switches over to the second page and won’t allow me to go back to the first app page. I also just discovered pressing the ctrl key while in a browser, it will drop my browser zoom to 30%.

I really don’t know how to explain it any differently, so I did a screen record. I did apply all updates, rebooted a few times, and tried both 5.15 and 5.17 kernels.

I would really appreciate any advice finding this issue and correcting it. Please let me know what information I can provide.

Screen record link here.

1 Like

The first b it of info required is which DE you’re trying! Sounds like it might be Gnome - but I mostly know XFCE these days, so…

Could be settings - could be flaky (or misset) keyboard or…

It is indeed Gnome 42. :slight_smile:

Edit: Just disabled all extensions, but it didn’t change anything. :frowning:

Here’s some details (from screenfetch):
OS: EndeavourOS rolling rolling
Kernel: x86_64 Linux 5.15.40-1-lts
Uptime: 42m
Packages: 1242
Shell: bash 5.1.16
Resolution: 1920x1080
DE: GNOME 42.1
WM: Mutter
WM Theme: Adwaita
GTK Theme: Adwaita [GTK2/3]
Icon Theme: Blue-Aurora
Font: Noto Sans, 10
Disk: 645G / 1.2T (61%)
CPU: Intel Core i7-7700HQ @ 8x 3.8GHz [46.0°C]
GPU: NVIDIA GeForce GTX 1050 Ti
RAM: 2655MiB / 15890MiB

Something you could try is to create another user and log in to that account and see if you see the same behavior there as well.

1 Like

Just tried, also no luck. I was hopeful though!

Me too :slightly_smiling_face:

I use mostly Gnome but honestly the issue you describe is beyond me. It could be any number of things.

Perhaps it could help trying to remember things you did before the issue started so you might be able to pinpoint the causes.

Honestly, all I can remember is applying updates after a few weeks of being offline. I did run into a keyring issue pertaining to Docker File /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)

I also just applied a Timeshift restore and still no fix. It’s quite strange!

1 Like

My gosh @pebcak and @freebird54 you’re not going to believe this. My mouse was defective. I’m not even joking and so glad I posted in Newbie! :joy: :rofl:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.