Storage set up with BTRFS RAID 0 /home partition

I want to set up my storage devices like this:
Drive 1: 250 Gib NVME /boot/efi and / partitions.
Drive 2 & 3 (4,5) 2 x 1 Tib SSDs BTRFS RAID 0 /home partition.

The last time I did this it worked and worked really well. This was back when I was on manjaro. In that case I could while inside the live environment issue the following command in a terminal prior to launching the installer. sudo mkfs.btrfs -f -d raid0 -m raid0 /dev/sda /dev/sdb
Noting that /dev/sda and /dev/sdb are just examples actual drive names may differ. This would create the array for the home partition. Then I would proceed to launch the installer and select manual partitioning (Calamares just as it is here) and could use it to set up the /boot/efi partitions on the nvme and mount them. Then the BTRFS drives would be detected by Calamares and all that was necessary was to mount the first drive in the array to /home. Then run the installer as usual. The end result would be a 2 Tib RAID0 /home partition. The issue here in EndeavourOS is that when I try this the BTRFS filesystem that is set up manually in terminal is not seen in Calamares. I’m still new to most of this and was wondering if there was a way to accomplish the same with different methods? I have read the archwiki but this particular topic is a long line of :rabbit: holes.

Whilst I cannot speak to the Calamares not seeing btrfs issue, I have to question; are you making sure you have another backup for your /home? With raid0 a drive failure will likely result in loss of everything on both drives, therefore your user data.

1 Like

Yes I am aware. This set up shouldn’t even be contemplated without a solid back up policy. You are correct I should have mentioned that. :grinning:

1 Like

Maybe it’s a kernel not aware of the changes issue? How about trying using gparted to format the raid0 as btrfs. If that cannot see the raid0 then it’s not calamares at fault, but rather that a reboot is required.

1 Like

Btrfs can add and remove devices online, and freely convert between RAID levels after the FS has been created.

So, why not just convert to btrfs-raid 0 AFTER a normal install?

Sort of off topic: There was some discussion about combining Luks encryption and btrfs raid 1 here.

1 Like

I thought about it but like I said as usual all the bits and pieces on how to do it I can find but not actually how to do it. I always feel like I am missing something when I read the arch wiki :yum:

Here is a complete walkthrough on how to set up btrfs raid 1 after an installation (it is pop os though the steps are the same as the btrfs magic happens post install): https://mutschler.eu/linux/install-guides/pop-os-btrfs-raid1/

I also plan to post the same tutorial for Manjaro using the awesome guide of @2000 here on the forums , but can’t find the time (or quiet space) right now to record it.

Hope that helps a bit?

3 Likes

This is copied over from your link. That is a lot of very useful information. Thank you for preparing that.

“With btrfs, it’s very easy to add that new drive to your /home .

  1. Create an unformatted partition on the new drive, let’s assume it’s /dev/sdb1 .
  2. Run the following command:
    btrfs device add /dev/sdb1 /home
  3. Now just issue btrfs filesystem usage /home and verify that free and total space have increased accordingly.
  4. You can now just continue using /home as always, but since you have two drives now, you can add a little redundancy. You can use RAID1 for metadata only with the following command:
    btrfs balance start -mconvert=raid1 /home

Substituting raid0 for 1 here should accomplish what I was looking to do :sweat_smile:. Consider this thread bookmarked :+1:

Thank you for the help.

2 Likes

Proof or it didn’t happen :sweat_smile: Thank you again.

[sudo] password for elloquin: 
Overall:
    Device size:		   3.64TiB
    Device allocated:		   2.07GiB
    Device unallocated:		   3.64TiB
    Device missing:		     0.00B
    Used:			  56.54MiB
    Free (estimated):		   3.64TiB	(min: 3.64TiB)
    Data ratio:			      1.00
    Metadata ratio:		      1.00
    Global reserve:		   3.25MiB	(used: 0.00B)

Data,single: Size:1.01GiB, Used:55.18MiB (5.35%)
   /dev/sda1	   8.00MiB
   /dev/sdb1	   1.00GiB

Metadata,RAID0: Size:1.00GiB, Used:1.34MiB (0.13%)
   /dev/sda1	 256.00MiB
   /dev/sdb1	 256.00MiB
   /dev/sdc1	 256.00MiB
   /dev/sdd1	 256.00MiB

System,RAID0: Size:64.00MiB, Used:16.00KiB (0.02%)
   /dev/sda1	  16.00MiB
   /dev/sdb1	  16.00MiB
   /dev/sdc1	  16.00MiB
   /dev/sdd1	  16.00MiB

Unallocated:
   /dev/sda1	 931.24GiB
   /dev/sdb1	 930.25GiB
   /dev/sdc1	 931.25GiB
   /dev/sdd1	 931.25GiB
[elloquin@elloquin-systemproductname ~]$

1 Like