Stop system upgrade

I have version 5.24.5 installed. I did upgrade to version 5.25

The trouble is several of my programs stopped working properly.
Using Timeshift I took my system back.
Is there something I could do to stop Pacman doing a system upgrade (but still do updates).
I have edited pacman.conf before to stop a program updating.

Any help would be great

Nik

No. The only way is to not upgrade anything. Partial updates are not recommended or supported and have a high likelihood of breaking your system.

If you’d prefer to have older things you’ll need to find a snapshot distro unfortunately. That’s just not how Endeavour works.

3 Likes

The terminology comes from a Debian/buntu experience.
Upgrade and update are the same result.
IIRC for Debian, a system upgrade is done when you go up a Debian version.
Arch has no Arch versions. There is only one version: the up-to-date version.

That was just a try to clarify misunderstandings. :person_shrugging:

1 Like

The partial update situation does not ALWAYS bite right away - but should be avoided if possible. Sometimes doing a downgrade and having it add the troublesome package(s) to the ignore list can be lived with for a while (while awaiting the fixes in the packages you ignored) - but there is a risk involved of a bigger mess down the road.

Your system, your decision - as long as the decision is made knowing the potential downside!

2 Likes

I really want to upgrade to 5.25, but at the mome t when I do upgrade there is two (of what I know) programs that do not work right (variaty and pdf arranger). There could be more that do not work right.

Are you using X11 or Wayland?

One of the “sideeffects” of using a distro which delivers the latest packages is that if something breaks, you have the opportunity of reporting it upstream to the developers for it to be fixed.

This will not only benefit the “bleeding edge” distro one is using but also those who will eventually get the new packages through their repositories.

If most things work for you on Plasma 5.25, you could perhaps live with a couple of applications not working for now and report to the developers for them to have an opportunity to fix them.

3 Likes

I just installed pdf arranger over here on Plasma 5.25 running on x11 and it works, is there a certain function in it that doesn’t work for you? I don’t use it, but turning pages, importing PDFs, inserting a blank page and creating a book all work over here.

2 Likes

I am running X11

Have you seen my other post?

It opens and then straight away crashes.

No I have not.

Did you reboot the system?

Yes I did

Just open the app again and then send a systemlog, that’s the only way to find the issue for us. PDF arranger does work over here, so there must be another issue.

Strangely I tried the upgrade again and this time the programs that did not work are now working. I am a happy bunny… system upgraded and all is well :smile:

Nik

1 Like

Glad it is all working for you!

Not so much …

the-arch-ways

:wink:

1 Like