Stop Baloo from indexing home folder?

Hi,
Often when I search for a file in Krunner or the application menu search, the results are spammed by various program files within my documents/downloads folder. In KDE file search settings, I have chosen to exclude $HOME, but the folder is indexed anyway. Likewise, excluding the documents and downloads folders does not stop them from being indexed. I have checked ~/.config/baloofilerc, and the settings are applying correctly.
Has anyone smarter than me been able to change this behaviour? Thanks.

You may need to disable baloo, clear its cache and re enable baloo for your settings to take effect.

I used balooctl purge, as well as balooctl disable then balooctl enable after applying all settings. Unfortunately no change.

I had a similar issue where I wanted to exclude “pCloud” folder.
I added:

exclude folders[$e]=$/home/limo/pCloudDrive/

to “~/.config/baloofilerc”
But I had to struggle with it for a while, purge, reboot,… but finally worked with me fine!
I guess this was because after I purge Baloo starts reindexing instantly based on the “old” ~/.config/baloofilerc

So I guess -after adding the exclude to ~/.config/baloofilerc- you have to disable and stop Baloo completely then purge, then reboot and restart Baloo again.

Just curious… if you want to exclude /home… why use Baloo in the first place? Why not uninstall it?

Looks to be working perfectly now!
For anyone facing the same issue, you must follow these steps in order:

  1. balooctl disable
  2. balooctl purge
  3. Reboot
  4. balooctl enable

And to answer your question:

Just curious… if you want to exclude /home… why use Baloo in the first place? Why not uninstall it?

I have a secondary drive with documents on it that would be nice to access from search. As far as I know there’s no search that offers better integration than Baloo does.

Issue resolved. Thank you!

I see.
It has been a long time for me since I had a “second” drive!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.