Stellarium 23.1 (AUR)

Anyone have idea’s why this software has tanked? It seemed to have been working fine earlier but this newest revision is all messed up with the graphics. I’ve installed it from AUR with the gpg key and it runs but the graphics are messed up bad. . . I’m using Nvidia driver on my computer. Previously earlier versions everything worked. I also installed the Windows version using wine (same version) . Got two desktop icons. One labeled ‘Angle mode’ works fine with my video but the other is also messed up . Any thoughts or idea’s . . . . I realize this isn’t Arches problem, should have ‘red’ flagged it if it doesn’t work in the repository as broken. I realize everything in AUR is use at your own risk. It was working well till now. Anyone know what’s going on or have a clue?


Greetings Rich.

Stellarium is available in a flatpak. You could try it to see if it works.

Otherwise, we would need more infomation, such as logs, etc.


I just installed Stellarium from Installs and runs fine. It is Version 0.22.2

1 Like

Looks like a mesa bug.

Downgrade to 22 and:

sudo ln -s /usr/lib/ /usr/lib/

All working.

1 Like

I’m running stellarium-bin 23.1.1 from AUR with Plasma. No issues, works fine here.

1 Like

There is also an AppImage which seems to be working:


Here’s a picture of my landscape from my backyard in stellarium 23.1.3 downloaded with pacseek. The landscapes that come with the program all look similar. It may be something with qt6 or nvidia or both I don’t know.

Rich :wink:

Here’s another screenshot off of my minipc that uses a AMD/ATI Renoir graphics chip. Same program on 2 different computers. (mini-pc) and a old 8350 Phenon-3 8-core processor and 6-gig 1060ti Nvidia graphics card.

Rich :wink:

I download the appimage file for 23.1 stellarium then I install appimagelauncher from AUR repository. I ran appimage launcher and it installed the program. After the program loaded up and ran, I have the same screen as in the first png file above. . . something is amiss . . . . I don’t know whats going on. The last verion worked fine. . . . .I also tried the downgrade command and picked an earlier version that showed up from a long list of early versions so I picked the previous version to downgrade to. It didn’t work. . . it said it was downgraded but upon initializing the software nothing happened. Even tried to start it from the command line in terminal. . . nothing.


See my post above you need to symlink libgps…

Stupid question . . . . if it is a Mesa bug how is it when I installed the OS selecting the Nvidia driver as the video graphics card? I was under the assumption if you wanted something other than Nvidia you select the other choices to give you Mesa or Noveau during installation of the OS from scratch? I’m no computer guru, just trying to understand how things work. Is the software app installation separate from what the OS installs for graphic drivers?

Rich :wink:

It is a stellarium bug with the new version of mesa.