Steam UI won't launch

When i try to open steam, it shows up on the bottom right of the task bar, but the UI won’t open. Here is the terminal output:[18140]: Running Steam on endeavouros rolling 64-bit[18140]: STEAM_RUNTIME is enabled automatically[18214]: Steam runtime environment up-to-date![18140]: Steam client's requirements are satisfied
[2023-06-26 11:07:33] Startup - updater built Jun 21 2023 21:17:38
[2023-06-26 11:07:33] Startup - Steam Client launched with: '/home/elias/.local/share/Steam/ubuntu12_32/steam'
06/26 11:07:33 Init: Installing breakpad exception handler for appid(steam)/version(1687386907)/tid(18271)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2023-06-26 11:07:33] Loading cached metrics from disk (/home/elias/.local/share/Steam/package/steam_client_metrics.bin)
[2023-06-26 11:07:33] Using the following download hosts for Public, Realm steamglobal
[2023-06-26 11:07:33] 1., /, Realm 'steamglobal', weight was 1000, source = 'update_ho
[2023-06-26 11:07:33] 2., /client/, Realm 'steamglobal', weight was 1, source = 'update_host
[2023-06-26 11:07:33] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-06-26 11:07:33] Checking for update on startup
[2023-06-26 11:07:33] Checking for available updates...
[2023-06-26 11:07:33] Downloading manifest:
[2023-06-26 11:07:33] Manifest download: send request
[2023-06-26 11:07:33] Manifest download: waiting for download to finish
[2023-06-26 11:07:33] Manifest download: finished
[2023-06-26 11:07:33] Download skipped: /steam_client_ubuntu12 version 1687386907, installed version 1687386907, existing pending v
ersion 0
[2023-06-26 11:07:33] Nothing to do
[2023-06-26 11:07:33] Verifying installation...
[2023-06-26 11:07:33] Performing checksum verification of executable files
[2023-06-26 11:07:34] Verification complete

(process:18271): GLib-GObject-CRITICAL **: 11:07:34.359: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(process:18271): GLib-GObject-CRITICAL **: 11:07:34.359: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Loaded SDL version 3.0.0-1782-g214d5daa3
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf0c08db0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf0c07500
/usr/share/themes/Breeze/gtk-2.0/widgets/entry:70: error: unexpected identifier 'direction', expected character '}'

(steam:18271): Gtk-WARNING **: 11:07:34.386: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Breeze/gtk-2.0/widgets/styles:36: error: invalid string constant "combobox_entry", expected valid string constant
GetWin32Stats: display was not open yet, good
GetWin32Stats: display was not open yet, good[18279]: Runtime for steamwebhelper: defaulting to /home/elias/.local/share/Steam/ubuntu12_64/steam-runtime-heavy[18279]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
CAppInfoCacheReadFromDiskThread took 41 milliseconds to initialize
Failed to init SteamVR because it isn't installed

(steam:18271): Gtk-WARNING **: 11:07:35.090: gtk_disable_setlocale() must be called before gtk_init()
local (potentially out of sync) copy of roaming config loaded - 8132 bytes.
BRefreshApplicationsInLibrary 1: 0ms
roaming config store loaded successfully - 8132 bytes.
migrating temporary roaming config store

(steam:18271): GLib-GObject-CRITICAL **: 11:07:36.847: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(steam:18271): GLib-GObject-CRITICAL **: 11:07:36.847: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
System startup time: 2.61 seconds

I have tried the solutions from and
none of them have worked, except launching with the steam -vgui to use the legacy UI, but the friends list shows as disconnected, and i can’t connect to it.
I have managed to get it working sometimes after using steam --reset several times, but it is not consistent, and it doesn’t work after a reboot unless i do it again.
I see many people had an issue with xdg-desktop-portal-gnome, but i don’t have that installed. I do have xdg-desktop-portal-kde, but i assume i need it, because i am using KDE.
All my nvidia packages are up to date. Here is from pacman -Qs nvidia:

local/egl-wayland 2:1.1.12-1
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.5-1
    Nvidia VDPAU library
local/lib32-nvidia-utils 535.54.03-2
    NVIDIA drivers utilities (32-bit)
local/lib32-opencl-nvidia 535.54.03-2
    OpenCL implemention for NVIDIA (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 535.54.03-1
    NVIDIA NV-CONTROL X extension
local/nvidia 535.54.03-3
    NVIDIA drivers for linux
local/nvidia-hook 1.3-1
    pacman hook for nvidia
local/nvidia-inst 23-5
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-installer-common 23-6
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-settings 535.54.03-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 535.54.03-1
    NVIDIA drivers utilities

I had the same issue. I believe it was an issue with the nvidia 535.54.03 driver. The 535.86.05 driver that was just released fixes the issue for me.

Yes, it fixed the issue for me too, another issue was with the libgudev and lib32-libgudev packages, if they were on 238-1 versions steam would not open at all, but downgrading them to 237-2 works.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.